aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 975bb519..0c4040fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -134,6 +134,12 @@ then
134 AC_DEFINE([HAVE_MESSAGES],[1],[Include error messages]) 134 AC_DEFINE([HAVE_MESSAGES],[1],[Include error messages])
135fi 135fi
136 136
137# optional: have zzuf, socat?
138AC_CHECK_PROG([HAVE_ZZUF],[zzuf], 1, 0)
139AC_CHECK_PROG([HAVE_SOCAT],[socat], 1, 0)
140
141AM_CONDITIONAL(HAVE_ZZUF, test 0 != $HAVE_ZZUF)
142AM_CONDITIONAL(HAVE_SOCAT, test 0 != $HAVE_SOCAT)
137 143
138AC_SUBST(CPPFLAGS) 144AC_SUBST(CPPFLAGS)
139AC_SUBST(LIBS) 145AC_SUBST(LIBS)
@@ -147,7 +153,10 @@ doc/Makefile
147m4/Makefile 153m4/Makefile
148src/Makefile 154src/Makefile
149src/include/Makefile 155src/include/Makefile
150src/daemon/Makefile]) 156src/daemon/Makefile
157src/examples/Makefile
158src/testcurl/Makefile
159src/testzzuf/Makefile])
151AC_OUTPUT 160AC_OUTPUT
152 161
153if test "$curl" != 1 162if test "$curl" != 1