aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 936550ce..fa572d5b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,7 +398,13 @@ if test "x$enable_thread_names" != "xno" && test "x$USE_THREADS" = "xposix"; the
398 SAVE_CFLAGS="$CFLAGS" 398 SAVE_CFLAGS="$CFLAGS"
399 LIBS="$PTHREAD_LIBS $LIBS" 399 LIBS="$PTHREAD_LIBS $LIBS"
400 CFLAGS="$CFLAGS $PTHREAD_CFLAGS" 400 CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
401 AC_CHECK_HEADERS([pthread_np.h],[],[],[AC_INCLUDES_DEFAULT]) 401 AC_CHECK_HEADERS([pthread_np.h],[],[],
402 [
403AC_INCLUDES_DEFAULT
404 [
405#include <pthread.h>
406 ]
407 ])
402 408
403 # Try to find how to set thread name by thread attributes. 409 # Try to find how to set thread name by thread attributes.
404 # If pthread_attr_setname_np(3) is not declared, it's not possible to detect 410 # If pthread_attr_setname_np(3) is not declared, it's not possible to detect