aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 416efbef..1712a724 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,16 +37,16 @@ AC_SUBST(LIB_VERSION_AGE)
37if test `uname -s` = "OS/390" 37if test `uname -s` = "OS/390"
38then 38then
39# configure binaries for z/OS 39# configure binaries for z/OS
40 if test -z $CC 40 if test -z "$CC"
41 then 41 then
42 CC=`pwd`"/contrib/xcc" 42 CC=`pwd`"/contrib/xcc"
43 chmod +x $CC || true 43 chmod +x $CC || true
44 fi 44 fi
45 if test -z $CPP 45 if test -z "$CPP"
46 then 46 then
47 CPP="c89 -E" 47 CPP="c89 -E"
48 fi 48 fi
49 if test -z $CXXCPP 49 if test -z "$CXXCPP"
50 then 50 then
51 CXXCPP="c++ -E -+" 51 CXXCPP="c++ -E -+"
52 fi 52 fi
@@ -143,7 +143,7 @@ AC_SUBST(PTHREAD_CPPFLAGS)
143AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files])) 143AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files]))
144 144
145# Check for optional headers 145# Check for optional headers
146AC_CHECK_HEADERS([sys/select.h sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h netinet/tcp.h time.h sys/socket.h sys/mman.h arpa/inet.h]) 146AC_CHECK_HEADERS([sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h netinet/tcp.h time.h sys/socket.h sys/mman.h arpa/inet.h sys/select.h])
147 147
148AC_CHECK_FUNCS(memmem) 148AC_CHECK_FUNCS(memmem)
149 149