aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2133dc9d..f9d28b21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,6 +141,7 @@ AC_CHECK_HEADERS([sys/select.h sys/types.h sys/time.h sys/msg.h netdb.h netinet/
141# IPv6 141# IPv6
142AC_MSG_CHECKING(for IPv6) 142AC_MSG_CHECKING(for IPv6)
143AC_TRY_COMPILE([ 143AC_TRY_COMPILE([
144#include <stdio.h>
144#if HAVE_NETINET_IN_H 145#if HAVE_NETINET_IN_H
145#include <netinet/in.h> 146#include <netinet/in.h>
146#endif 147#endif
@@ -151,6 +152,7 @@ AC_TRY_COMPILE([
151int af=AF_INET6; 152int af=AF_INET6;
152int pf=PF_INET6; 153int pf=PF_INET6;
153struct sockaddr_in6 sa; 154struct sockaddr_in6 sa;
155printf("%d %d %p\n", af, pf, &sa);
154],[ 156],[
155have_inet6=yes; 157have_inet6=yes;
156AC_DEFINE([HAVE_INET6], [1], [Provides IPv6 headers]) 158AC_DEFINE([HAVE_INET6], [1], [Provides IPv6 headers])