aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index b874ee68..456650c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -843,21 +843,6 @@ AC_SEARCH_LIBS(sendmsg, socket, AC_DEFINE([HAVE_SENDMSG],1,[Define if your platf
843AC_MSG_CHECKING([whether writev is available]) 843AC_MSG_CHECKING([whether writev is available])
844AC_CHECK_FUNCS([writev]) 844AC_CHECK_FUNCS([writev])
845 845
846# check MSG_MORE defined
847AC_MSG_CHECKING([whether MSG_MORE is defined])
848AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
849#include <sys/types.h>
850#include <sys/socket.h>
851]],[[return MSG_MORE;]]
852 )],
853 [
854 AC_MSG_RESULT(yes)
855 AC_DEFINE(HAVE_MSG_MORE, [1], [have MSG_MORE])
856 ],
857 [
858 AC_MSG_RESULT(no)
859 ])
860
861# set GCC options 846# set GCC options
862# use '-fno-strict-aliasing', but only if the compiler 847# use '-fno-strict-aliasing', but only if the compiler
863# and linker can take it 848# and linker can take it