aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f9d28b21..27772b33 100644
--- a/configure.ac
+++ b/configure.ac
@@ -136,7 +136,7 @@ AC_SUBST(PTHREAD_CPPFLAGS)
136AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files])) 136AC_CHECK_HEADERS([fcntl.h math.h errno.h limits.h stdio.h locale.h sys/stat.h sys/types.h pthread.h],,AC_MSG_ERROR([Compiling libmicrohttpd requires standard UNIX headers files]))
137 137
138# Check for optional headers 138# Check for optional headers
139AC_CHECK_HEADERS([sys/select.h sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h time.h sys/socket.h sys/mman.h arpa/inet.h]) 139AC_CHECK_HEADERS([sys/select.h sys/types.h sys/time.h sys/msg.h netdb.h netinet/in.h netinet/tcp.h time.h sys/socket.h sys/mman.h arpa/inet.h])
140 140
141# IPv6 141# IPv6
142AC_MSG_CHECKING(for IPv6) 142AC_MSG_CHECKING(for IPv6)
@@ -161,6 +161,8 @@ have_inet6=no
161) 161)
162AC_MSG_RESULT($have_inet6) 162AC_MSG_RESULT($have_inet6)
163 163
164# TCP_CORK
165AC_CHECK_DECL([TCP_CORK], [], [], [[#include <netinet/tcp.h>]])
164 166
165# libcurl (required for testing) 167# libcurl (required for testing)
166SAVE_LIBS=$LIBS 168SAVE_LIBS=$LIBS