aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8a7c3f8..7a74e240 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1173,6 +1173,48 @@ AS_VAR_IF([[enable_httpupgrade]],[["yes"]],
1173AM_CONDITIONAL([ENABLE_UPGRADE], [[test "x$enable_httpupgrade" = "xyes"]]) 1173AM_CONDITIONAL([ENABLE_UPGRADE], [[test "x$enable_httpupgrade" = "xyes"]])
1174AC_MSG_RESULT([[$enable_httpupgrade]]) 1174AC_MSG_RESULT([[$enable_httpupgrade]])
1175 1175
1176# Check for fork() and waitpid(). They are used for tests.
1177AC_MSG_CHECKING([[for fork()]])
1178AC_LINK_IFELSE(
1179 [
1180 AC_LANG_PROGRAM(
1181 [[
1182#ifdef HAVE_SYS_TYPES_H
1183#include <sys/types.h>
1184#endif
1185#ifdef HAVE_UNISTD_H
1186#include <unistd.h>
1187#endif
1188 ]], [[
1189 pid_t p = fork ();
1190 if (0 == p)
1191 return 1;
1192 ]])
1193 ], [
1194 AC_DEFINE([[HAVE_FORK]], [[1]], [Define to 1 if you have the usable `fork' function.])
1195 AC_MSG_RESULT([[yes]])
1196
1197 AC_MSG_CHECKING([[for waitpid()]])
1198 AC_LINK_IFELSE(
1199 [
1200 AC_LANG_PROGRAM(
1201 [[
1202#include <sys/wait.h>
1203 ]], [[
1204 pid_t p = fork ();
1205 if (0 == p)
1206 return 1;
1207 waitpid (p, (void*)0, 0)
1208 ]])
1209 ], [
1210 AC_DEFINE([[HAVE_WAITPID]], [[1]], [Define to 1 if you have the usable `waitpid' function.])
1211 AC_MSG_RESULT([[yes]])
1212 ],[
1213 AC_MSG_RESULT([[no]])
1214 ])
1215],[
1216 AC_MSG_RESULT([[no]])
1217])
1176 1218
1177 1219
1178MHD_LIB_LDFLAGS="$MHD_LIB_LDFLAGS -export-dynamic -no-undefined" 1220MHD_LIB_LDFLAGS="$MHD_LIB_LDFLAGS -export-dynamic -no-undefined"