aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 31 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b73f3cc3..6589b2d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1072,6 +1072,37 @@ AC_CHECK_HEADER([[search.h]],
1072 1072
1073AM_CONDITIONAL([MHD_HAVE_TSEARCH], [[test "x$ac_cv_header_search_h" = xyes && test "x$HAVE_TSEARCH" = "x1" && test "x$REPLACE_TSEARCH" != "x1"]]) 1073AM_CONDITIONAL([MHD_HAVE_TSEARCH], [[test "x$ac_cv_header_search_h" = xyes && test "x$HAVE_TSEARCH" = "x1" && test "x$REPLACE_TSEARCH" != "x1"]])
1074 1074
1075# Check for types sizes
1076AC_CACHE_CHECK([size of tv_sec member of struct timeval], [mhd_cv_size_timeval_tv_sec],
1077 [
1078 AC_COMPUTE_INT([mhd_cv_size_timeval_tv_sec], [((long int)sizeof(test_var.tv_sec))],
1079 [[
1080#ifdef HAVE_SYS_TIME_H
1081#include <sys/time.h>
1082#endif /* HAVE_SYS_TIME_H */
1083#ifdef HAVE_TIME_H
1084#include <time.h>
1085#endif /* HAVE_TIME_H */
1086#if HAVE_SYS_TYPES_H
1087#include <sys/types.h>
1088#endif /* HAVE_SYS_TYPES_H */
1089static struct timeval test_var;
1090 ]],
1091 [
1092 # The size is used only to exclude additional checks/comparision in code
1093 # to avoid compiler warnings. With larger size MHD code will use
1094 # additional checks which ensure that value will fit but it may produce
1095 # a harmless compiler warning.
1096 AC_MSG_WARN([The size cannot be determined, assuming 8.])
1097 mhd_cv_size_timeval_tv_sec=8
1098 ]
1099 )
1100 ]
1101)
1102AC_DEFINE_UNQUOTED([SIZEOF_STRUCT_TIMEVAL_TV_SEC], [$mhd_cv_size_timeval_tv_sec],
1103 [The size of `tv_sec' member of `struct timeval', as computed by sizeof])
1104AC_CHECK_SIZEOF([uint64_t], [], [[#include <stdint.h>]])
1105
1075AC_CHECK_HEADERS([dlfcn.h],[have_tlsplugin=yes],[have_tlsplugin=no], [AC_INCLUDES_DEFAULT]) 1106AC_CHECK_HEADERS([dlfcn.h],[have_tlsplugin=yes],[have_tlsplugin=no], [AC_INCLUDES_DEFAULT])
1076AM_CONDITIONAL([MHD_HAVE_TLS_PLUGIN], [[test "x$have_tlsplugin" = xyes]]) 1107AM_CONDITIONAL([MHD_HAVE_TLS_PLUGIN], [[test "x$have_tlsplugin" = xyes]])
1077 1108