aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 366a7864..5562a61d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -268,6 +268,18 @@ AM_CONDITIONAL(USE_PRIVATE_PLIBC_H, test x$our_private_plibc_h = x1)
268 268
269AC_CHECK_FUNCS_ONCE(memmem) 269AC_CHECK_FUNCS_ONCE(memmem)
270AC_CHECK_FUNCS_ONCE(accept4) 270AC_CHECK_FUNCS_ONCE(accept4)
271AC_MSG_CHECKING([[for gmtime_s]])
272AC_LINK_IFELSE(
273 [AC_LANG_PROGRAM(
274 [[ #include <time.h>]], [[struct tm now; time_t t; time (&t); gmtime_s (&now, &t)]])
275 ],
276 [
277 AC_DEFINE([HAVE_GMTIME_S], [1], [Define to 1 if you have `gmtime_s' function (only for W32).])
278 AC_MSG_RESULT([[yes]])
279 ],
280 [AC_MSG_RESULT([[no]])
281 ])
282
271 283
272AC_COMPILE_IFELSE( 284AC_COMPILE_IFELSE(
273 [AC_LANG_PROGRAM( 285 [AC_LANG_PROGRAM(