aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index 5ce824cc..e0174f40 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -11,6 +11,7 @@ libmicrohttpd_la_SOURCES = \
11 connection.c connection.h \ 11 connection.c connection.h \
12 daemon.c \ 12 daemon.c \
13 internal.c internal.h \ 13 internal.c internal.h \
14 memorypool.c memorypool.h \
14 plibc.h \ 15 plibc.h \
15 response.c response.h 16 response.c response.h
16 17
@@ -31,7 +32,9 @@ check_PROGRAMS = \
31 daemontest \ 32 daemontest \
32 daemontest_get \ 33 daemontest_get \
33 daemontest_post \ 34 daemontest_post \
34 daemontest_put 35 daemontest_put \
36 daemontest_post11 \
37 daemontest_put11
35 38
36TESTS = $(check_PROGRAMS) 39TESTS = $(check_PROGRAMS)
37 40
@@ -46,18 +49,29 @@ daemontest_get_LDADD = \
46 $(top_builddir)/src/daemon/libmicrohttpd.la \ 49 $(top_builddir)/src/daemon/libmicrohttpd.la \
47 @LIBCURL@ 50 @LIBCURL@
48 51
49
50daemontest_post_SOURCES = \ 52daemontest_post_SOURCES = \
51 daemontest_post.c 53 daemontest_post.c
52daemontest_post_LDADD = \ 54daemontest_post_LDADD = \
53 $(top_builddir)/src/daemon/libmicrohttpd.la \ 55 $(top_builddir)/src/daemon/libmicrohttpd.la \
54 @LIBCURL@ 56 @LIBCURL@
55 57
56
57daemontest_put_SOURCES = \ 58daemontest_put_SOURCES = \
58 daemontest_put.c 59 daemontest_put.c
59daemontest_put_LDADD = \ 60daemontest_put_LDADD = \
60 $(top_builddir)/src/daemon/libmicrohttpd.la \ 61 $(top_builddir)/src/daemon/libmicrohttpd.la \
61 @LIBCURL@ 62 @LIBCURL@
62 63
64daemontest_post11_SOURCES = \
65 daemontest_post.c
66daemontest_post11_LDADD = \
67 $(top_builddir)/src/daemon/libmicrohttpd.la \
68 @LIBCURL@
69
70
71daemontest_put11_SOURCES = \
72 daemontest_put.c
73daemontest_put11_LDADD = \
74 $(top_builddir)/src/daemon/libmicrohttpd.la \
75 @LIBCURL@
76
63endif \ No newline at end of file 77endif \ No newline at end of file