aboutsummaryrefslogtreecommitdiff
path: root/src/daemon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/daemon/Makefile.am')
-rw-r--r--src/daemon/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/src/daemon/Makefile.am b/src/daemon/Makefile.am
index b35b45d7..3ac9f312 100644
--- a/src/daemon/Makefile.am
+++ b/src/daemon/Makefile.am
@@ -3,7 +3,7 @@ SUBDIRS = .
3INCLUDES = -I$(top_srcdir)/src/include 3INCLUDES = -I$(top_srcdir)/src/include
4 4
5if HAVE_GNU_LD 5if HAVE_GNU_LD
6 retaincommand=-Wl,--retain-symbols-file -Wl,SYMBOLS 6 retaincommand=-Wl,--retain-symbols-file -Wl,$(srcdir)/SYMBOLS
7endif 7endif
8 8
9EXTRA_DIST = SYMBOLS 9EXTRA_DIST = SYMBOLS
@@ -12,7 +12,7 @@ lib_LTLIBRARIES = \
12 libmicrohttpd.la 12 libmicrohttpd.la
13 13
14libmicrohttpd_la_LDFLAGS = \ 14libmicrohttpd_la_LDFLAGS = \
15 -export-dynamic -version-info 2:0:0 $(retaincommand) 15 -export-dynamic -version-info 2:1:1 $(retaincommand)
16libmicrohttpd_la_SOURCES = \ 16libmicrohttpd_la_SOURCES = \
17 connection.c connection.h \ 17 connection.c connection.h \
18 reason_phrase.c reason_phrase.h \ 18 reason_phrase.c reason_phrase.h \
@@ -46,11 +46,13 @@ check_PROGRAMS = \
46 daemontest_get \ 46 daemontest_get \
47 daemontest_post \ 47 daemontest_post \
48 daemontest_postform \ 48 daemontest_postform \
49 daemontest_post_loop \
49 daemontest_put \ 50 daemontest_put \
50 daemontest_large_put \ 51 daemontest_large_put \
51 daemontest_get11 \ 52 daemontest_get11 \
52 daemontest_post11 \ 53 daemontest_post11 \
53 daemontest_postform11 \ 54 daemontest_postform11 \
55 daemontest_post_loop11 \
54 daemontest_put11 \ 56 daemontest_put11 \
55 daemontest_large_put11 \ 57 daemontest_large_put11 \
56 daemontest_long_header 58 daemontest_long_header
@@ -80,6 +82,12 @@ daemontest_postform_LDADD = \
80 $(top_builddir)/src/daemon/libmicrohttpd.la \ 82 $(top_builddir)/src/daemon/libmicrohttpd.la \
81 @LIBCURL@ 83 @LIBCURL@
82 84
85daemontest_post_loop_SOURCES = \
86 daemontest_post_loop.c
87daemontest_post_loop_LDADD = \
88 $(top_builddir)/src/daemon/libmicrohttpd.la \
89 @LIBCURL@
90
83daemontest_put_SOURCES = \ 91daemontest_put_SOURCES = \
84 daemontest_put.c 92 daemontest_put.c
85daemontest_put_LDADD = \ 93daemontest_put_LDADD = \
@@ -104,6 +112,12 @@ daemontest_postform11_LDADD = \
104 $(top_builddir)/src/daemon/libmicrohttpd.la \ 112 $(top_builddir)/src/daemon/libmicrohttpd.la \
105 @LIBCURL@ 113 @LIBCURL@
106 114
115daemontest_post_loop11_SOURCES = \
116 daemontest_post_loop.c
117daemontest_post_loop11_LDADD = \
118 $(top_builddir)/src/daemon/libmicrohttpd.la \
119 @LIBCURL@
120
107daemontest_put11_SOURCES = \ 121daemontest_put11_SOURCES = \
108 daemontest_put.c 122 daemontest_put.c
109daemontest_put11_LDADD = \ 123daemontest_put11_LDADD = \