aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 540dd26d..fbd1920d 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -6,6 +6,8 @@ AM_CPPFLAGS = \
6 6
7AM_CFLAGS = @LIBGCRYPT_CFLAGS@ 7AM_CFLAGS = @LIBGCRYPT_CFLAGS@
8 8
9CPU_COUNT_DEF = -DCPU_COUNT=$(CPU_COUNT)
10
9if USE_COVERAGE 11if USE_COVERAGE
10 AM_CFLAGS += --coverage 12 AM_CFLAGS += --coverage
11endif 13endif
@@ -72,6 +74,8 @@ demo_SOURCES = \
72 demo.c 74 demo.c
73demo_CFLAGS = \ 75demo_CFLAGS = \
74 $(PTHREAD_CFLAGS) $(AM_CFLAGS) 76 $(PTHREAD_CFLAGS) $(AM_CFLAGS)
77demo_CPPFLAGS = \
78 $(AM_CPPFLAGS) $(CPU_COUNT_DEF)
75demo_LDADD = \ 79demo_LDADD = \
76 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 80 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
77 $(PTHREAD_LIBS) -lmagic 81 $(PTHREAD_LIBS) -lmagic
@@ -87,11 +91,15 @@ mhd2spdy_LDADD = \
87 91
88benchmark_SOURCES = \ 92benchmark_SOURCES = \
89 benchmark.c 93 benchmark.c
94benchmark_CPPFLAGS = \
95 $(AM_CPPFLAGS) $(CPU_COUNT_DEF)
90benchmark_LDADD = \ 96benchmark_LDADD = \
91 $(top_builddir)/src/microhttpd/libmicrohttpd.la 97 $(top_builddir)/src/microhttpd/libmicrohttpd.la
92 98
93benchmark_https_SOURCES = \ 99benchmark_https_SOURCES = \
94 benchmark_https.c 100 benchmark_https.c
101benchmark_https_CPPFLAGS = \
102 $(AM_CPPFLAGS) $(CPU_COUNT_DEF)
95benchmark_https_LDADD = \ 103benchmark_https_LDADD = \
96 $(top_builddir)/src/microhttpd/libmicrohttpd.la 104 $(top_builddir)/src/microhttpd/libmicrohttpd.la
97 105