aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 070ccf94..0f4b3d6d 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -19,7 +19,11 @@ if ENABLE_SPDY
19spdyex = \ 19spdyex = \
20 spdy_event_loop \ 20 spdy_event_loop \
21 spdy_fileserver \ 21 spdy_fileserver \
22 spdy_response_with_callback 22 spdy_response_with_callback
23
24if HAVE_SPDYLAY
25spdyex += mhd2spdy
26endif
23endif 27endif
24 28
25 29
@@ -74,6 +78,15 @@ demo_LDADD = \
74 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 78 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
75 -lmagic 79 -lmagic
76 80
81mhd2spdy_SOURCES = \
82 mhd2spdy.c \
83 mhd2spdy_spdy.c mhd2spdy_spdy.h \
84 mhd2spdy_http.c mhd2spdy_http.h \
85 mhd2spdy_structures.c mhd2spdy_structures.h
86mhd2spdy_LDADD = \
87 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
88 -lssl -lcrypto -lspdylay
89
77benchmark_SOURCES = \ 90benchmark_SOURCES = \
78 benchmark.c 91 benchmark.c
79benchmark_LDADD = \ 92benchmark_LDADD = \