aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index f8147bbf..563f16e4 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -42,10 +42,10 @@ noinst_PROGRAMS += https_fileserver_example
42endif 42endif
43if HAVE_POSTPROCESSOR 43if HAVE_POSTPROCESSOR
44noinst_PROGRAMS += \ 44noinst_PROGRAMS += \
45 post_example 45 post_example
46if HAVE_MAGIC 46if HAVE_MAGIC
47bin_PROGRAMS = \ 47bin_PROGRAMS = \
48 demo 48 demo
49endif 49endif
50endif 50endif
51 51
@@ -69,10 +69,12 @@ minimal_example_LDADD = \
69 $(top_builddir)/src/microhttpd/libmicrohttpd.la 69 $(top_builddir)/src/microhttpd/libmicrohttpd.la
70 70
71demo_SOURCES = \ 71demo_SOURCES = \
72 demo.c 72 demo.c
73demo_CFLAGS = \
74 $(PTHREAD_CFLAGS) $(AM_CFLAGS)
73demo_LDADD = \ 75demo_LDADD = \
74 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 76 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
75 -lmagic 77 $(PTHREAD_LIBS) -lmagic
76 78
77mhd2spdy_SOURCES = \ 79mhd2spdy_SOURCES = \
78 mhd2spdy.c \ 80 mhd2spdy.c \