aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index aae7ff48..58f4b4aa 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -38,7 +38,6 @@ endif
38if HAVE_POSTPROCESSOR 38if HAVE_POSTPROCESSOR
39noinst_PROGRAMS += \ 39noinst_PROGRAMS += \
40 post_example 40 post_example
41if HAVE_MAGIC
42if HAVE_POSIX_THREADS 41if HAVE_POSIX_THREADS
43noinst_PROGRAMS += demo 42noinst_PROGRAMS += demo
44if ENABLE_HTTPS 43if ENABLE_HTTPS
@@ -46,7 +45,6 @@ noinst_PROGRAMS += demo_https
46endif 45endif
47endif 46endif
48endif 47endif
49endif
50 48
51if ENABLE_DAUTH 49if ENABLE_DAUTH
52noinst_PROGRAMS += \ 50noinst_PROGRAMS += \
@@ -100,7 +98,10 @@ demo_CPPFLAGS = \
100 $(AM_CPPFLAGS) $(CPU_COUNT_DEF) 98 $(AM_CPPFLAGS) $(CPU_COUNT_DEF)
101demo_LDADD = \ 99demo_LDADD = \
102 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 100 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
103 $(PTHREAD_LIBS) -lmagic 101 $(PTHREAD_LIBS)
102if HAVE_LIBMAGIC
103demo_LDADD += -lmagic
104endif
104 105
105demo_https_SOURCES = \ 106demo_https_SOURCES = \
106 demo_https.c 107 demo_https.c
@@ -110,7 +111,10 @@ demo_https_CPPFLAGS = \
110 $(AM_CPPFLAGS) $(CPU_COUNT_DEF) 111 $(AM_CPPFLAGS) $(CPU_COUNT_DEF)
111demo_https_LDADD = \ 112demo_https_LDADD = \
112 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 113 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
113 $(PTHREAD_LIBS) -lmagic 114 $(PTHREAD_LIBS)
115if HAVE_LIBMAGIC
116demo_https_LDADD += -lmagic
117endif
114 118
115benchmark_SOURCES = \ 119benchmark_SOURCES = \
116 benchmark.c 120 benchmark.c