diff options
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r-- | src/examples/Makefile.am | 12 |
1 files changed, 8 insertions, 4 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am index aae7ff48..58f4b4aa 100644 --- a/src/examples/Makefile.am +++ b/src/examples/Makefile.am | |||
@@ -38,7 +38,6 @@ endif | |||
38 | if HAVE_POSTPROCESSOR | 38 | if HAVE_POSTPROCESSOR |
39 | noinst_PROGRAMS += \ | 39 | noinst_PROGRAMS += \ |
40 | post_example | 40 | post_example |
41 | if HAVE_MAGIC | ||
42 | if HAVE_POSIX_THREADS | 41 | if HAVE_POSIX_THREADS |
43 | noinst_PROGRAMS += demo | 42 | noinst_PROGRAMS += demo |
44 | if ENABLE_HTTPS | 43 | if ENABLE_HTTPS |
@@ -46,7 +45,6 @@ noinst_PROGRAMS += demo_https | |||
46 | endif | 45 | endif |
47 | endif | 46 | endif |
48 | endif | 47 | endif |
49 | endif | ||
50 | 48 | ||
51 | if ENABLE_DAUTH | 49 | if ENABLE_DAUTH |
52 | noinst_PROGRAMS += \ | 50 | noinst_PROGRAMS += \ |
@@ -100,7 +98,10 @@ demo_CPPFLAGS = \ | |||
100 | $(AM_CPPFLAGS) $(CPU_COUNT_DEF) | 98 | $(AM_CPPFLAGS) $(CPU_COUNT_DEF) |
101 | demo_LDADD = \ | 99 | demo_LDADD = \ |
102 | $(top_builddir)/src/microhttpd/libmicrohttpd.la \ | 100 | $(top_builddir)/src/microhttpd/libmicrohttpd.la \ |
103 | $(PTHREAD_LIBS) -lmagic | 101 | $(PTHREAD_LIBS) |
102 | if HAVE_LIBMAGIC | ||
103 | demo_LDADD += -lmagic | ||
104 | endif | ||
104 | 105 | ||
105 | demo_https_SOURCES = \ | 106 | demo_https_SOURCES = \ |
106 | demo_https.c | 107 | demo_https.c |
@@ -110,7 +111,10 @@ demo_https_CPPFLAGS = \ | |||
110 | $(AM_CPPFLAGS) $(CPU_COUNT_DEF) | 111 | $(AM_CPPFLAGS) $(CPU_COUNT_DEF) |
111 | demo_https_LDADD = \ | 112 | demo_https_LDADD = \ |
112 | $(top_builddir)/src/microhttpd/libmicrohttpd.la \ | 113 | $(top_builddir)/src/microhttpd/libmicrohttpd.la \ |
113 | $(PTHREAD_LIBS) -lmagic | 114 | $(PTHREAD_LIBS) |
115 | if HAVE_LIBMAGIC | ||
116 | demo_https_LDADD += -lmagic | ||
117 | endif | ||
114 | 118 | ||
115 | benchmark_SOURCES = \ | 119 | benchmark_SOURCES = \ |
116 | benchmark.c | 120 | benchmark.c |