aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am32
1 files changed, 29 insertions, 3 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 3d693b23..340f7824 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -1,10 +1,16 @@
1SUBDIRS = . 1SUBDIRS = .
2 2
3INCLUDES = -I$(top_srcdir)/src/include 3AM_CPPFLAGS = -I$(top_srcdir)/src/include
4 4
5# example programs 5# example programs
6 6
7noinst_PROGRAMS = minimal_example querystring_example fileserver_example fileserver_example_external_select 7noinst_PROGRAMS = \
8https_server_example \
9https_echo_client_example \
10minimal_example \
11querystring_example \
12fileserver_example \
13fileserver_example_external_select
8 14
9minimal_example_SOURCES = \ 15minimal_example_SOURCES = \
10 minimal_example.c 16 minimal_example.c
@@ -21,9 +27,29 @@ fileserver_example_SOURCES = \
21fileserver_example_LDADD = \ 27fileserver_example_LDADD = \
22 $(top_builddir)/src/daemon/libmicrohttpd.la 28 $(top_builddir)/src/daemon/libmicrohttpd.la
23 29
24
25fileserver_example_external_select_SOURCES = \ 30fileserver_example_external_select_SOURCES = \
26 fileserver_example_external_select.c 31 fileserver_example_external_select.c
27fileserver_example_external_select_LDADD = \ 32fileserver_example_external_select_LDADD = \
28 $(top_builddir)/src/daemon/libmicrohttpd.la 33 $(top_builddir)/src/daemon/libmicrohttpd.la
29 34
35https_server_example_CPPFLAGS = \
36 $(GNUTLS_CPPFLAGS) \
37 -I$(top_srcdir)/src/daemon
38https_server_example_SOURCES = \
39 https_server_example.c
40https_server_example_LDADD = \
41 $(top_builddir)/src/daemon/libmicrohttpd.la
42https_server_example_LDFLAGS = \
43 -L$(GNUTLS_LIB_PATH) \
44 -lgnutls
45
46https_echo_client_example_CPPFLAGS = \
47 $(GNUTLS_CPPFLAGS) \
48 -I$(top_srcdir)/src/daemon
49https_echo_client_example_SOURCES = \
50 https_echo_client_example.c
51https_echo_client_example_LDADD = \
52 $(top_builddir)/src/daemon/libmicrohttpd.la
53https_echo_client_example_LDFLAGS = \
54 -L$(GNUTLS_LIB_PATH) \
55 -lgnutls