aboutsummaryrefslogtreecommitdiff
path: root/src/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/examples/Makefile.am')
-rw-r--r--src/examples/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/examples/Makefile.am b/src/examples/Makefile.am
index 545a236a..ce01107a 100644
--- a/src/examples/Makefile.am
+++ b/src/examples/Makefile.am
@@ -68,6 +68,11 @@ noinst_PROGRAMS += \
68endif 68endif
69endif 69endif
70 70
71if HAVE_ZLIB
72noinst_PROGRAMS += \
73 http_compression
74endif
75
71if HAVE_W32 76if HAVE_W32
72AM_CFLAGS += -DWINDOWS 77AM_CFLAGS += -DWINDOWS
73endif 78endif
@@ -198,3 +203,11 @@ https_fileserver_example_CPPFLAGS = \
198 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS) 203 $(AM_CPPFLAGS) $(GNUTLS_CPPFLAGS)
199https_fileserver_example_LDADD = \ 204https_fileserver_example_LDADD = \
200 $(top_builddir)/src/microhttpd/libmicrohttpd.la 205 $(top_builddir)/src/microhttpd/libmicrohttpd.la
206
207http_compression_SOURCES = \
208 http_compression.c
209http_compression_LDADD = \
210 $(top_builddir)/src/microhttpd/libmicrohttpd.la
211if HAVE_ZLIB
212 http_compression_LDADD += -lz
213endif \ No newline at end of file