aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 1ae2b3f3..a98fbd9e 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -167,6 +167,18 @@ check_PROGRAMS = \
167 test_daemon \ 167 test_daemon \
168 test_response_entries \ 168 test_response_entries \
169 test_postprocessor_md \ 169 test_postprocessor_md \
170 test_client_put_shutdown \
171 test_client_put_close \
172 test_client_put_hard_close \
173 test_client_put_steps_shutdown \
174 test_client_put_steps_close \
175 test_client_put_steps_hard_close \
176 test_client_put_chunked_shutdown \
177 test_client_put_chunked_close \
178 test_client_put_chunked_hard_close \
179 test_client_put_chunked_steps_shutdown \
180 test_client_put_chunked_steps_close \
181 test_client_put_chunked_steps_hard_close \
170 test_options 182 test_options
171 183
172if HAVE_POSIX_THREADS 184if HAVE_POSIX_THREADS
@@ -389,3 +401,63 @@ test_options_SOURCES = \
389 test_options.c 401 test_options.c
390test_options_LDADD = \ 402test_options_LDADD = \
391 $(top_builddir)/src/microhttpd/libmicrohttpd.la 403 $(top_builddir)/src/microhttpd/libmicrohttpd.la
404
405test_client_put_shutdown_SOURCES = \
406 test_client_put_stop.c
407test_client_put_shutdown_LDADD = \
408 libmicrohttpd.la
409
410test_client_put_close_SOURCES = \
411 test_client_put_stop.c
412test_client_put_close_LDADD = \
413 libmicrohttpd.la
414
415test_client_put_hard_close_SOURCES = \
416 test_client_put_stop.c
417test_client_put_hard_close_LDADD = \
418 libmicrohttpd.la
419
420test_client_put_steps_shutdown_SOURCES = \
421 test_client_put_stop.c
422test_client_put_steps_shutdown_LDADD = \
423 libmicrohttpd.la
424
425test_client_put_steps_close_SOURCES = \
426 test_client_put_stop.c
427test_client_put_steps_close_LDADD = \
428 libmicrohttpd.la
429
430test_client_put_steps_hard_close_SOURCES = \
431 test_client_put_stop.c
432test_client_put_steps_hard_close_LDADD = \
433 libmicrohttpd.la
434
435test_client_put_chunked_shutdown_SOURCES = \
436 test_client_put_stop.c
437test_client_put_chunked_shutdown_LDADD = \
438 libmicrohttpd.la
439
440test_client_put_chunked_close_SOURCES = \
441 test_client_put_stop.c
442test_client_put_chunked_close_LDADD = \
443 libmicrohttpd.la
444
445test_client_put_chunked_hard_close_SOURCES = \
446 test_client_put_stop.c
447test_client_put_chunked_hard_close_LDADD = \
448 libmicrohttpd.la
449
450test_client_put_chunked_steps_shutdown_SOURCES = \
451 test_client_put_stop.c
452test_client_put_chunked_steps_shutdown_LDADD = \
453 libmicrohttpd.la
454
455test_client_put_chunked_steps_close_SOURCES = \
456 test_client_put_stop.c
457test_client_put_chunked_steps_close_LDADD = \
458 libmicrohttpd.la
459
460test_client_put_chunked_steps_hard_close_SOURCES = \
461 test_client_put_stop.c
462test_client_put_chunked_steps_hard_close_LDADD = \
463 libmicrohttpd.la