aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am28
1 files changed, 25 insertions, 3 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index f303b3f9..2c59876a 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -62,13 +62,23 @@ libmicrohttpd_la_SOURCES = \
62 mhd_limits.h mhd_byteorder.h \ 62 mhd_limits.h mhd_byteorder.h \
63 sysfdsetsize.c sysfdsetsize.h \ 63 sysfdsetsize.c sysfdsetsize.h \
64 mhd_str.c mhd_str.h \ 64 mhd_str.c mhd_str.h \
65 mhd_threads.c mhd_threads.h \ 65 mhd_assert.h \
66 mhd_locks.h mhd_assert.h \
67 mhd_sockets.c mhd_sockets.h \ 66 mhd_sockets.c mhd_sockets.h \
68 mhd_itc.c mhd_itc.h mhd_itc_types.h \ 67 mhd_itc.c mhd_itc.h mhd_itc_types.h \
69 mhd_compat.c mhd_compat.h \ 68 mhd_compat.c mhd_compat.h \
70 response.c response.h 69 response.c response.h
71 70
71if USE_POSIX_THREADS
72libmicrohttpd_la_SOURCES += \
73 mhd_threads.c mhd_threads.h \
74 mhd_locks.h
75endif
76if USE_W32_THREADS
77libmicrohttpd_la_SOURCES += \
78 mhd_threads.c mhd_threads.h \
79 mhd_locks.h
80endif
81
72libmicrohttpd_la_CPPFLAGS = \ 82libmicrohttpd_la_CPPFLAGS = \
73 $(AM_CPPFLAGS) $(MHD_LIB_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS) \ 83 $(AM_CPPFLAGS) $(MHD_LIB_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS) \
74 -DBUILDING_MHD_LIB=1 84 -DBUILDING_MHD_LIB=1
@@ -150,9 +160,19 @@ check_PROGRAMS = \
150 160
151if HAVE_POSIX_THREADS 161if HAVE_POSIX_THREADS
152if ENABLE_UPGRADE 162if ENABLE_UPGRADE
163if USE_POSIX_THREADS
164 check_PROGRAMS += test_upgrade
165endif
166if USE_W32_THREADS
153 check_PROGRAMS += test_upgrade 167 check_PROGRAMS += test_upgrade
168endif
154if ENABLE_HTTPS 169if ENABLE_HTTPS
155 check_PROGRAMS += test_upgrade_tls 170if USE_POSIX_THREADS
171check_PROGRAMS += test_upgrade_tls
172endif
173if USE_W32_THREADS
174check_PROGRAMS += test_upgrade_tls
175endif
156endif 176endif
157endif 177endif
158endif 178endif
@@ -170,6 +190,7 @@ TESTS = $(check_PROGRAMS)
170# on Cygwin as this ability is deliberately ignored on Cygwin 190# on Cygwin as this ability is deliberately ignored on Cygwin
171# to improve compatibility with core OS. 191# to improve compatibility with core OS.
172if !CYGWIN_TARGET 192if !CYGWIN_TARGET
193if USE_POSIX_THREADS
173if HAVE_LISTEN_SHUTDOWN 194if HAVE_LISTEN_SHUTDOWN
174check_PROGRAMS += \ 195check_PROGRAMS += \
175 test_shutdown_select \ 196 test_shutdown_select \
@@ -180,6 +201,7 @@ check_PROGRAMS += \
180 test_shutdown_poll_ignore 201 test_shutdown_poll_ignore
181endif 202endif
182endif 203endif
204endif
183 205
184test_start_stop_SOURCES = \ 206test_start_stop_SOURCES = \
185 test_start_stop.c 207 test_start_stop.c