aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am46
1 files changed, 44 insertions, 2 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 10a32f59..c4c15608 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -171,11 +171,25 @@ libmicrohttpd_la_SOURCES += \
171 mhd_bithelpers.h mhd_byteorder.h mhd_align.h 171 mhd_bithelpers.h mhd_byteorder.h mhd_align.h
172if ENABLE_MD5 172if ENABLE_MD5
173libmicrohttpd_la_SOURCES += \ 173libmicrohttpd_la_SOURCES += \
174 mhd_md5_wrap.h
175if ! ENABLE_MD5_EXT
176libmicrohttpd_la_SOURCES += \
174 md5.c md5.h 177 md5.c md5.h
178else
179libmicrohttpd_la_SOURCES += \
180 md5_ext.c md5_ext.h
181endif
175endif 182endif
176if ENABLE_SHA256 183if ENABLE_SHA256
177libmicrohttpd_la_SOURCES += \ 184libmicrohttpd_la_SOURCES += \
185 mhd_sha256_wrap.h
186if ! ENABLE_SHA256_EXT
187libmicrohttpd_la_SOURCES += \
178 sha256.c sha256.h 188 sha256.c sha256.h
189else
190libmicrohttpd_la_SOURCES += \
191 sha256_ext.c sha256_ext.h
192endif
179endif 193endif
180if ENABLE_SHA512_256 194if ENABLE_SHA512_256
181libmicrohttpd_la_SOURCES += \ 195libmicrohttpd_la_SOURCES += \
@@ -462,12 +476,40 @@ test_http_reasons_SOURCES = \
462 reason_phrase.c mhd_str.c mhd_str.h 476 reason_phrase.c mhd_str.c mhd_str.h
463 477
464test_md5_SOURCES = \ 478test_md5_SOURCES = \
465 test_md5.c test_helpers.h \ 479 test_md5.c test_helpers.h mhd_md5_wrap.h ../include/mhd_options.h
480if ! ENABLE_MD5_EXT
481test_md5_SOURCES += \
466 md5.c md5.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h 482 md5.c md5.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h
483test_md5_CPPFLAGS = $(AM_CPPFLAGS)
484test_md5_CFLAGS = $(AM_CFLAGS)
485test_md5_LDFLAGS = $(AM_LDFLAGS)
486test_md5_LDADD = $(LDADD)
487else
488test_md5_SOURCES += \
489 md5_ext.c md5_ext.h
490test_md5_CPPFLAGS = $(AM_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS)
491test_md5_CFLAGS = $(AM_CFLAGS) $(MHD_TLS_LIB_CFLAGS)
492test_md5_LDFLAGS = $(AM_LDFLAGS) $(MHD_TLS_LIB_LDFLAGS)
493test_md5_LDADD = $(MHD_TLS_LIBDEPS) $(LDADD)
494endif
467 495
468test_sha256_SOURCES = \ 496test_sha256_SOURCES = \
469 test_sha256.c test_helpers.h \ 497 test_sha256.c test_helpers.h mhd_sha256_wrap.h ../include/mhd_options.h
498if ! ENABLE_SHA256_EXT
499test_sha256_SOURCES += \
470 sha256.c sha256.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h 500 sha256.c sha256.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h
501test_sha256_CPPFLAGS = $(AM_CPPFLAGS)
502test_sha256_CFLAGS = $(AM_CFLAGS)
503test_sha256_LDFLAGS = $(AM_LDFLAGS)
504test_sha256_LDADD = $(LDADD)
505else
506test_sha256_SOURCES += \
507 sha256_ext.c sha256_ext.h
508test_sha256_CPPFLAGS = $(AM_CPPFLAGS) $(MHD_TLS_LIB_CPPFLAGS)
509test_sha256_CFLAGS = $(AM_CFLAGS) $(MHD_TLS_LIB_CFLAGS)
510test_sha256_LDFLAGS = $(AM_LDFLAGS) $(MHD_TLS_LIB_LDFLAGS)
511test_sha256_LDADD = $(MHD_TLS_LIBDEPS) $(LDADD)
512endif
471 513
472test_sha512_256_SOURCES = \ 514test_sha512_256_SOURCES = \
473 test_sha512_256.c test_helpers.h \ 515 test_sha512_256.c test_helpers.h \