aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index cf7e7f76..b7bae34c 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -256,6 +256,11 @@ endif
256endif 256endif
257endif 257endif
258 258
259if HAVE_ANYAUTH
260check_PROGRAMS += \
261 test_auth_parse
262endif
263
259TESTS = $(check_PROGRAMS) 264TESTS = $(check_PROGRAMS)
260 265
261test_start_stop_SOURCES = \ 266test_start_stop_SOURCES = \
@@ -429,6 +434,9 @@ test_sha1_SOURCES = \
429 test_sha1.c test_helpers.h \ 434 test_sha1.c test_helpers.h \
430 sha1.c sha1.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h 435 sha1.c sha1.h mhd_bithelpers.h mhd_byteorder.h mhd_align.h
431 436
437test_auth_parse_SOURCES = \
438 test_auth_parse.c gen_auth.c gen_auth.h mhd_str.h mhd_str.c
439
432test_options_SOURCES = \ 440test_options_SOURCES = \
433 test_options.c 441 test_options.c
434test_options_LDADD = \ 442test_options_LDADD = \
@@ -498,3 +506,4 @@ test_set_panic_SOURCES = \
498 test_set_panic.c 506 test_set_panic.c
499test_set_panic_LDADD = \ 507test_set_panic_LDADD = \
500 libmicrohttpd.la 508 libmicrohttpd.la
509