aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index f6e1e2bd..f491f13b 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -264,6 +264,10 @@ if ENABLE_DAUTH
264check_PROGRAMS += \ 264check_PROGRAMS += \
265 test_str_quote 265 test_str_quote
266endif 266endif
267if ENABLE_BAUTH
268check_PROGRAMS += \
269 test_str_base64
270endif
267 271
268TESTS = $(check_PROGRAMS) 272TESTS = $(check_PROGRAMS)
269 273
@@ -440,10 +444,13 @@ test_sha1_SOURCES = \
440 444
441test_auth_parse_SOURCES = \ 445test_auth_parse_SOURCES = \
442 test_auth_parse.c gen_auth.c gen_auth.h mhd_str.h mhd_str.c mhd_assert.h 446 test_auth_parse.c gen_auth.c gen_auth.h mhd_str.h mhd_str.c mhd_assert.h
443 447
444test_str_quote_SOURCES = \ 448test_str_quote_SOURCES = \
445 test_str_quote.c mhd_str.h mhd_str.c mhd_assert.h 449 test_str_quote.c mhd_str.h mhd_str.c mhd_assert.h
446 450
451test_str_base64_SOURCES = \
452 test_str_base64.c mhd_str.h mhd_str.c mhd_assert.h
453
447test_options_SOURCES = \ 454test_options_SOURCES = \
448 test_options.c 455 test_options.c
449test_options_LDADD = \ 456test_options_LDADD = \