aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am92
1 files changed, 92 insertions, 0 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
new file mode 100644
index 00000000..bb9dead6
--- /dev/null
+++ b/src/microhttpd/Makefile.am
@@ -0,0 +1,92 @@
1if USE_PRIVATE_PLIBC_H
2 PLIBC_INCLUDE = -I$(top_srcdir)/src/include/plibc
3endif
4
5AM_CPPFLAGS = \
6 $(PLIBC_INCLUDE) \
7 -I$(top_srcdir)/src/include \
8 -I$(top_srcdir)/src/daemon \
9 @LIBGCRYPT_CFLAGS@
10
11EXTRA_DIST = EXPORT.sym
12
13lib_LTLIBRARIES = \
14 libmicrohttpd.la
15
16
17libmicrohttpd_la_SOURCES = \
18 connection.c connection.h \
19 reason_phrase.c reason_phrase.h \
20 daemon.c \
21 internal.c internal.h \
22 memorypool.c memorypool.h \
23 response.c response.h
24libmicrohttpd_la_LDFLAGS = \
25 $(MHD_LIB_LDFLAGS) \
26 -version-info @LIB_VERSION_CURRENT@:@LIB_VERSION_REVISION@:@LIB_VERSION_AGE@
27
28if USE_COVERAGE
29 AM_CFLAGS = --coverage
30endif
31
32if !HAVE_TSEARCH
33libmicrohttpd_la_SOURCES += \
34 tsearch.c tsearch.h
35endif
36
37if HAVE_POSTPROCESSOR
38libmicrohttpd_la_SOURCES += \
39 postprocessor.c
40endif
41
42if ENABLE_DAUTH
43libmicrohttpd_la_SOURCES += \
44 digestauth.c \
45 md5.c md5.h
46endif
47
48if ENABLE_BAUTH
49libmicrohttpd_la_SOURCES += \
50 basicauth.c \
51 base64.c base64.h
52endif
53
54if ENABLE_HTTPS
55libmicrohttpd_la_SOURCES += \
56 connection_https.c connection_https.h
57libmicrohttpd_la_LIBADD = -lgnutls @LIBGCRYPT_LIBS@
58endif
59
60
61
62check_PROGRAMS = \
63 test_daemon
64
65if HAVE_POSTPROCESSOR
66check_PROGRAMS += \
67 test_postprocessor \
68 test_postprocessor_large \
69 test_postprocessor_amp
70endif
71
72TESTS = $(check_PROGRAMS)
73
74test_daemon_SOURCES = \
75 test_daemon.c
76test_daemon_LDADD = \
77 $(top_builddir)/src/daemon/libmicrohttpd.la
78
79test_postprocessor_SOURCES = \
80 test_postprocessor.c
81test_postprocessor_LDADD = \
82 $(top_builddir)/src/daemon/libmicrohttpd.la
83
84test_postprocessor_amp_SOURCES = \
85 test_postprocessor_amp.c
86test_postprocessor_amp_LDADD = \
87 $(top_builddir)/src/daemon/libmicrohttpd.la
88
89test_postprocessor_large_SOURCES = \
90 test_postprocessor_large.c
91test_postprocessor_large_LDADD = \
92 $(top_builddir)/src/daemon/libmicrohttpd.la