aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index d0f403c6..b033fc92 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -16,12 +16,6 @@ AM_CPPFLAGS = \
16-I$(top_srcdir)/src/include \ 16-I$(top_srcdir)/src/include \
17$(LIBCURL_CPPFLAGS) 17$(LIBCURL_CPPFLAGS)
18 18
19if !HAVE_W32
20if HAVE_CURL_BINARY
21CURL_FORK_TEST = test_get_response_cleanup
22endif
23endif
24
25if HAVE_CURL 19if HAVE_CURL
26check_PROGRAMS = \ 20check_PROGRAMS = \
27 test_start_stop \ 21 test_start_stop \
@@ -46,15 +40,23 @@ check_PROGRAMS = \
46 test_termination \ 40 test_termination \
47 test_timeout \ 41 test_timeout \
48 test_callback \ 42 test_callback \
49 $(CURL_FORK_TEST) \
50 perf_get 43 perf_get
51 44
45if HAVE_FORK_WAITPID
46if HAVE_CURL_BINARY
47check_PROGRAMS += test_get_response_cleanup
48endif
49endif
50
52if HAVE_POSIX_THREADS 51if HAVE_POSIX_THREADS
53check_PROGRAMS += \ 52check_PROGRAMS += \
54 test_quiesce \ 53 test_quiesce \
55 test_quiesce_stream \
56 test_concurrent_stop \ 54 test_concurrent_stop \
57 perf_get_concurrent 55 perf_get_concurrent
56
57if HAVE_CURL_BINARY
58check_PROGRAMS += test_quiesce_stream
59endif
58endif 60endif
59 61
60if HAVE_POSTPROCESSOR 62if HAVE_POSTPROCESSOR