aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index 45992576..fda0e437 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -19,6 +19,10 @@ AM_CPPFLAGS = \
19-I$(top_srcdir)/src/include \ 19-I$(top_srcdir)/src/include \
20$(LIBCURL_CPPFLAGS) 20$(LIBCURL_CPPFLAGS)
21 21
22if !HAVE_W32
23PERF_GET_CONCURRENT=perf_get_concurrent
24endif
25
22check_PROGRAMS = \ 26check_PROGRAMS = \
23 daemontest_get \ 27 daemontest_get \
24 daemontest_get_sendfile \ 28 daemontest_get_sendfile \
@@ -43,7 +47,10 @@ check_PROGRAMS = \
43 daemontest_put_chunked \ 47 daemontest_put_chunked \
44 daemontest_iplimit11 \ 48 daemontest_iplimit11 \
45 daemontest_termination \ 49 daemontest_termination \
46 daemontest_timeout 50 daemontest_timeout \
51 perf_get $(PERF_GET_CONCURRENT)
52
53
47noinst_PROGRAMS = \ 54noinst_PROGRAMS = \
48 daemon_options_test 55 daemon_options_test
49 56
@@ -70,6 +77,20 @@ daemontest_get_LDADD = \
70 $(top_builddir)/src/daemon/libmicrohttpd.la \ 77 $(top_builddir)/src/daemon/libmicrohttpd.la \
71 @LIBCURL@ 78 @LIBCURL@
72 79
80perf_get_SOURCES = \
81 perf_get.c \
82 gauger.h
83perf_get_LDADD = \
84 $(top_builddir)/src/daemon/libmicrohttpd.la \
85 @LIBCURL@
86
87perf_get_concurrent_SOURCES = \
88 perf_get_concurrent.c \
89 gauger.h
90perf_get_concurrent_LDADD = \
91 $(top_builddir)/src/daemon/libmicrohttpd.la \
92 @LIBCURL@
93
73daemontest_digestauth_SOURCES = \ 94daemontest_digestauth_SOURCES = \
74 daemontest_digestauth.c 95 daemontest_digestauth.c
75daemontest_digestauth_LDADD = \ 96daemontest_digestauth_LDADD = \