aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index 36e78739..1a7b6a24 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -21,6 +21,7 @@ $(LIBCURL_CPPFLAGS)
21 21
22if !HAVE_W32 22if !HAVE_W32
23PERF_GET_CONCURRENT=perf_get_concurrent 23PERF_GET_CONCURRENT=perf_get_concurrent
24CURL_FORK_TEST=daemontest_get_response_cleanup
24endif 25endif
25 26
26check_PROGRAMS = \ 27check_PROGRAMS = \
@@ -49,6 +50,7 @@ check_PROGRAMS = \
49 daemontest_termination \ 50 daemontest_termination \
50 daemontest_timeout \ 51 daemontest_timeout \
51 test_callback \ 52 test_callback \
53 $(CURL_FORK_TEST) \
52 perf_get $(PERF_GET_CONCURRENT) 54 perf_get $(PERF_GET_CONCURRENT)
53 55
54 56
@@ -110,6 +112,11 @@ daemontest_get_sendfile_LDADD = \
110 $(top_builddir)/src/daemon/libmicrohttpd.la \ 112 $(top_builddir)/src/daemon/libmicrohttpd.la \
111 @LIBCURL@ 113 @LIBCURL@
112 114
115daemontest_get_response_cleanup_SOURCES = \
116 daemontest_get_response_cleanup.c
117daemontest_get_response_cleanup_LDADD = \
118 $(top_builddir)/src/daemon/libmicrohttpd.la
119
113daemontest_get_chunked_SOURCES = \ 120daemontest_get_chunked_SOURCES = \
114 daemontest_get_chunked.c 121 daemontest_get_chunked.c
115daemontest_get_chunked_LDADD = \ 122daemontest_get_chunked_LDADD = \