aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am78
1 files changed, 38 insertions, 40 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index 934587d7..892ffceb 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -12,7 +12,6 @@ AM_CPPFLAGS = \
12-I$(top_srcdir) \ 12-I$(top_srcdir) \
13-I$(top_srcdir)/src/microhttpd \ 13-I$(top_srcdir)/src/microhttpd \
14-I$(top_srcdir)/src/include \ 14-I$(top_srcdir)/src/include \
15-I$(top_srcdir)/src/platform \
16$(LIBCURL_CPPFLAGS) 15$(LIBCURL_CPPFLAGS)
17 16
18if !HAVE_W32 17if !HAVE_W32
@@ -57,7 +56,7 @@ if HAVE_POSTPROCESSOR
57 test_post_loop \ 56 test_post_loop \
58 test_post11 \ 57 test_post11 \
59 test_postform11 \ 58 test_postform11 \
60 test_post_loop11 59 test_post_loop11
61endif 60endif
62 61
63noinst_PROGRAMS = \ 62noinst_PROGRAMS = \
@@ -90,33 +89,33 @@ test_get_SOURCES = \
90 test_get.c 89 test_get.c
91test_get_LDADD = \ 90test_get_LDADD = \
92 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 91 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
93 @LIBCURL@ 92 @LIBCURL@
94 93
95test_quiesce_SOURCES = \ 94test_quiesce_SOURCES = \
96 test_quiesce.c 95 test_quiesce.c
97test_quiesce_LDADD = \ 96test_quiesce_LDADD = \
98 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 97 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
99 @LIBCURL@ 98 @LIBCURL@
100 99
101test_callback_SOURCES = \ 100test_callback_SOURCES = \
102 test_callback.c 101 test_callback.c
103test_callback_LDADD = \ 102test_callback_LDADD = \
104 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 103 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
105 @LIBCURL@ 104 @LIBCURL@
106 105
107perf_get_SOURCES = \ 106perf_get_SOURCES = \
108 perf_get.c \ 107 perf_get.c \
109 gauger.h 108 gauger.h
110perf_get_LDADD = \ 109perf_get_LDADD = \
111 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 110 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
112 @LIBCURL@ 111 @LIBCURL@
113 112
114perf_get_concurrent_SOURCES = \ 113perf_get_concurrent_SOURCES = \
115 perf_get_concurrent.c \ 114 perf_get_concurrent.c \
116 gauger.h 115 gauger.h
117perf_get_concurrent_LDADD = \ 116perf_get_concurrent_LDADD = \
118 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 117 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
119 @LIBCURL@ 118 @LIBCURL@
120 119
121test_digestauth_SOURCES = \ 120test_digestauth_SOURCES = \
122 test_digestauth.c 121 test_digestauth.c
@@ -131,56 +130,55 @@ test_digestauth_with_arguments_LDADD = \
131 @LIBCURL@ @LIBGCRYPT_LIBS@ 130 @LIBCURL@ @LIBGCRYPT_LIBS@
132 131
133test_get_sendfile_SOURCES = \ 132test_get_sendfile_SOURCES = \
134 test_get_sendfile.c \ 133 test_get_sendfile.c
135 ../platform/platform_interface.h
136if HAVE_W32
137test_get_sendfile_SOURCES += \
138 ../platform/w32functions.h ../platform/w32functions.c
139endif
140test_get_sendfile_LDADD = \ 134test_get_sendfile_LDADD = \
141 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 135 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
142 @LIBCURL@ 136 @LIBCURL@
137if HAVE_W32
138test_get_sendfile_LDADD +=
139 $(top_builddir)/src/platform/libmicrohttpd_w32.la
140endif
143 141
144test_urlparse_SOURCES = \ 142test_urlparse_SOURCES = \
145 test_urlparse.c 143 test_urlparse.c
146test_urlparse_LDADD = \ 144test_urlparse_LDADD = \
147 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 145 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
148 @LIBCURL@ 146 @LIBCURL@
149 147
150test_get_response_cleanup_SOURCES = \ 148test_get_response_cleanup_SOURCES = \
151 test_get_response_cleanup.c 149 test_get_response_cleanup.c
152test_get_response_cleanup_LDADD = \ 150test_get_response_cleanup_LDADD = \
153 $(top_builddir)/src/microhttpd/libmicrohttpd.la 151 $(top_builddir)/src/microhttpd/libmicrohttpd.la
154 152
155test_get_chunked_SOURCES = \ 153test_get_chunked_SOURCES = \
156 test_get_chunked.c 154 test_get_chunked.c
157test_get_chunked_LDADD = \ 155test_get_chunked_LDADD = \
158 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 156 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
159 @LIBCURL@ 157 @LIBCURL@
160 158
161test_post_SOURCES = \ 159test_post_SOURCES = \
162 test_post.c 160 test_post.c
163test_post_LDADD = \ 161test_post_LDADD = \
164 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 162 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
165 @LIBCURL@ 163 @LIBCURL@
166 164
167test_process_headers_SOURCES = \ 165test_process_headers_SOURCES = \
168 test_process_headers.c 166 test_process_headers.c
169test_process_headers_LDADD = \ 167test_process_headers_LDADD = \
170 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 168 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
171 @LIBCURL@ 169 @LIBCURL@
172 170
173test_parse_cookies_SOURCES = \ 171test_parse_cookies_SOURCES = \
174 test_parse_cookies.c 172 test_parse_cookies.c
175test_parse_cookies_LDADD = \ 173test_parse_cookies_LDADD = \
176 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 174 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
177 @LIBCURL@ 175 @LIBCURL@
178 176
179test_process_arguments_SOURCES = \ 177test_process_arguments_SOURCES = \
180 test_process_arguments.c 178 test_process_arguments.c
181test_process_arguments_LDADD = \ 179test_process_arguments_LDADD = \
182 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 180 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
183 @LIBCURL@ 181 @LIBCURL@
184 182
185test_postform_SOURCES = \ 183test_postform_SOURCES = \
186 test_postform.c 184 test_postform.c
@@ -192,41 +190,41 @@ test_post_loop_SOURCES = \
192 test_post_loop.c 190 test_post_loop.c
193test_post_loop_LDADD = \ 191test_post_loop_LDADD = \
194 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 192 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
195 @LIBCURL@ 193 @LIBCURL@
196 194
197test_put_SOURCES = \ 195test_put_SOURCES = \
198 test_put.c 196 test_put.c
199test_put_LDADD = \ 197test_put_LDADD = \
200 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 198 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
201 @LIBCURL@ 199 @LIBCURL@
202 200
203test_put_chunked_SOURCES = \ 201test_put_chunked_SOURCES = \
204 test_put_chunked.c 202 test_put_chunked.c
205test_put_chunked_LDADD = \ 203test_put_chunked_LDADD = \
206 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 204 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
207 @LIBCURL@ 205 @LIBCURL@
208 206
209test_get11_SOURCES = \ 207test_get11_SOURCES = \
210 test_get.c 208 test_get.c
211test_get11_LDADD = \ 209test_get11_LDADD = \
212 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 210 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
213 @LIBCURL@ 211 @LIBCURL@
214 212
215test_get_sendfile11_SOURCES = \ 213test_get_sendfile11_SOURCES = \
216 test_get_sendfile.c 214 test_get_sendfile.c
217if HAVE_W32
218test_get_sendfile11_SOURCES += \
219 ../platform/w32functions.h ../platform/w32functions.c
220endif
221test_get_sendfile11_LDADD = \ 215test_get_sendfile11_LDADD = \
222 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 216 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
223 @LIBCURL@ 217 @LIBCURL@
218if HAVE_W32
219test_get_sendfile11_LDADD += \
220 $(top_builddir)/src/platform/libmicrohttpd_w32.la
221endif
224 222
225test_post11_SOURCES = \ 223test_post11_SOURCES = \
226 test_post.c 224 test_post.c
227test_post11_LDADD = \ 225test_post11_LDADD = \
228 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 226 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
229 @LIBCURL@ 227 @LIBCURL@
230 228
231test_postform11_SOURCES = \ 229test_postform11_SOURCES = \
232 test_postform.c 230 test_postform.c
@@ -238,53 +236,53 @@ test_post_loop11_SOURCES = \
238 test_post_loop.c 236 test_post_loop.c
239test_post_loop11_LDADD = \ 237test_post_loop11_LDADD = \
240 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 238 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
241 @LIBCURL@ 239 @LIBCURL@
242 240
243test_put11_SOURCES = \ 241test_put11_SOURCES = \
244 test_put.c 242 test_put.c
245test_put11_LDADD = \ 243test_put11_LDADD = \
246 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 244 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
247 @LIBCURL@ 245 @LIBCURL@
248 246
249test_large_put_SOURCES = \ 247test_large_put_SOURCES = \
250 test_large_put.c 248 test_large_put.c
251test_large_put_LDADD = \ 249test_large_put_LDADD = \
252 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 250 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
253 @LIBCURL@ 251 @LIBCURL@
254 252
255test_large_put11_SOURCES = \ 253test_large_put11_SOURCES = \
256 test_large_put.c 254 test_large_put.c
257test_large_put11_LDADD = \ 255test_large_put11_LDADD = \
258 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 256 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
259 @LIBCURL@ 257 @LIBCURL@
260 258
261test_long_header_SOURCES = \ 259test_long_header_SOURCES = \
262 test_long_header.c 260 test_long_header.c
263test_long_header_LDADD = \ 261test_long_header_LDADD = \
264 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 262 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
265 @LIBCURL@ 263 @LIBCURL@
266 264
267test_long_header11_SOURCES = \ 265test_long_header11_SOURCES = \
268 test_long_header.c 266 test_long_header.c
269test_long_header11_LDADD = \ 267test_long_header11_LDADD = \
270 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 268 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
271 @LIBCURL@ 269 @LIBCURL@
272 270
273test_iplimit11_SOURCES = \ 271test_iplimit11_SOURCES = \
274 test_iplimit.c 272 test_iplimit.c
275test_iplimit11_LDADD = \ 273test_iplimit11_LDADD = \
276 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 274 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
277 @LIBCURL@ 275 @LIBCURL@
278 276
279test_termination_SOURCES = \ 277test_termination_SOURCES = \
280 test_termination.c 278 test_termination.c
281test_termination_LDADD = \ 279test_termination_LDADD = \
282 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 280 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
283 @LIBCURL@ 281 @LIBCURL@
284 282
285test_timeout_SOURCES = \ 283test_timeout_SOURCES = \
286 test_timeout.c 284 test_timeout.c
287test_timeout_LDADD = \ 285test_timeout_LDADD = \
288 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 286 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
289 @LIBCURL@ 287 @LIBCURL@
290 288