aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index 510516c3..47ebda5a 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -17,7 +17,6 @@ AM_CPPFLAGS = \
17$(LIBCURL_CPPFLAGS) 17$(LIBCURL_CPPFLAGS)
18 18
19if !HAVE_W32 19if !HAVE_W32
20TEST_CONCURRENT_STOP=test_concurrent_stop
21if HAVE_CURL_BINARY 20if HAVE_CURL_BINARY
22CURL_FORK_TEST = test_get_response_cleanup 21CURL_FORK_TEST = test_get_response_cleanup
23endif 22endif
@@ -30,7 +29,6 @@ check_PROGRAMS = \
30 test_get_sendfile \ 29 test_get_sendfile \
31 test_urlparse \ 30 test_urlparse \
32 test_put \ 31 test_put \
33 $(TEST_CONCURRENT_STOP) \
34 test_process_headers \ 32 test_process_headers \
35 test_process_arguments \ 33 test_process_arguments \
36 test_parse_cookies \ 34 test_parse_cookies \
@@ -53,6 +51,7 @@ check_PROGRAMS = \
53if HAVE_POSIX_THREADS 51if HAVE_POSIX_THREADS
54check_PROGRAMS += \ 52check_PROGRAMS += \
55 test_quiesce \ 53 test_quiesce \
54 test_concurrent_stop \
56 perf_get_concurrent 55 perf_get_concurrent
57endif 56endif
58 57
@@ -89,9 +88,11 @@ test_start_stop_LDADD = \
89 88
90test_concurrent_stop_SOURCES = \ 89test_concurrent_stop_SOURCES = \
91 test_concurrent_stop.c 90 test_concurrent_stop.c
91test_concurrent_stop_CFLAGS = \
92 $(PTHREAD_CFLAGS) $(AM_CFLAGS)
92test_concurrent_stop_LDADD = \ 93test_concurrent_stop_LDADD = \
93 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 94 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
94 @LIBCURL@ 95 $(PTHREAD_LIBS) @LIBCURL@
95 96
96test_options_SOURCES = \ 97test_options_SOURCES = \
97 test_options.c 98 test_options.c