aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/Makefile.am')
-rw-r--r--src/testcurl/Makefile.am230
1 files changed, 115 insertions, 115 deletions
diff --git a/src/testcurl/Makefile.am b/src/testcurl/Makefile.am
index d09b1338..40cc169e 100644
--- a/src/testcurl/Makefile.am
+++ b/src/testcurl/Makefile.am
@@ -22,51 +22,51 @@ $(LIBCURL_CPPFLAGS)
22if !HAVE_W32 22if !HAVE_W32
23PERF_GET_CONCURRENT=perf_get_concurrent 23PERF_GET_CONCURRENT=perf_get_concurrent
24if HAVE_CURL_BINARY 24if HAVE_CURL_BINARY
25CURL_FORK_TEST=daemontest_get_response_cleanup 25CURL_FORK_TEST = test_get_response_cleanup
26endif 26endif
27endif 27endif
28 28
29check_PROGRAMS = \ 29check_PROGRAMS = \
30 test_start_stop \ 30 test_start_stop \
31 daemontest_get \ 31 test_get \
32 daemontest_get_sendfile \ 32 test_get_sendfile \
33 daemontest_urlparse \ 33 test_urlparse \
34 daemontest_put \ 34 test_put \
35 daemontest_process_headers \ 35 test_process_headers \
36 daemontest_process_arguments \ 36 test_process_arguments \
37 daemontest_parse_cookies \ 37 test_parse_cookies \
38 daemontest_large_put \ 38 test_large_put \
39 daemontest_get11 \ 39 test_get11 \
40 daemontest_get_sendfile11 \ 40 test_get_sendfile11 \
41 daemontest_put11 \ 41 test_put11 \
42 daemontest_large_put11 \ 42 test_large_put11 \
43 daemontest_long_header \ 43 test_long_header \
44 daemontest_long_header11 \ 44 test_long_header11 \
45 daemontest_get_chunked \ 45 test_get_chunked \
46 daemontest_put_chunked \ 46 test_put_chunked \
47 daemontest_iplimit11 \ 47 test_iplimit11 \
48 daemontest_termination \ 48 test_termination \
49 daemontest_timeout \ 49 test_timeout \
50 test_callback \ 50 test_callback \
51 $(CURL_FORK_TEST) \ 51 $(CURL_FORK_TEST) \
52 perf_get $(PERF_GET_CONCURRENT) 52 perf_get $(PERF_GET_CONCURRENT)
53 53
54if HAVE_POSTPROCESSOR 54if HAVE_POSTPROCESSOR
55 check_PROGRAMS += \ 55 check_PROGRAMS += \
56 daemontest_post \ 56 test_post \
57 daemontest_postform \ 57 test_postform \
58 daemontest_post_loop \ 58 test_post_loop \
59 daemontest_post11 \ 59 test_post11 \
60 daemontest_postform11 \ 60 test_postform11 \
61 daemontest_post_loop11 61 test_post_loop11
62endif 62endif
63 63
64noinst_PROGRAMS = \ 64noinst_PROGRAMS = \
65 daemon_options_test 65 test_options
66 66
67if ENABLE_DAUTH 67if ENABLE_DAUTH
68 check_PROGRAMS += \ 68 check_PROGRAMS += \
69 daemontest_digestauth daemontest_digestauth_with_arguments 69 test_digestauth test_digestauth_with_arguments
70endif 70endif
71 71
72TESTS = $(check_PROGRAMS) 72TESTS = $(check_PROGRAMS)
@@ -81,14 +81,14 @@ test_start_stop_SOURCES = \
81test_start_stop_LDADD = \ 81test_start_stop_LDADD = \
82 $(top_builddir)/src/daemon/libmicrohttpd.la 82 $(top_builddir)/src/daemon/libmicrohttpd.la
83 83
84daemon_options_test_SOURCES = \ 84test_options_SOURCES = \
85 daemon_options_test.c 85 test_options.c
86daemon_options_test_LDADD = \ 86test_options_LDADD = \
87 $(top_builddir)/src/daemon/libmicrohttpd.la 87 $(top_builddir)/src/daemon/libmicrohttpd.la
88 88
89daemontest_get_SOURCES = \ 89test_get_SOURCES = \
90 daemontest_get.c 90 test_get.c
91daemontest_get_LDADD = \ 91test_get_LDADD = \
92 $(top_builddir)/src/daemon/libmicrohttpd.la \ 92 $(top_builddir)/src/daemon/libmicrohttpd.la \
93 @LIBCURL@ 93 @LIBCURL@
94 94
@@ -112,164 +112,164 @@ perf_get_concurrent_LDADD = \
112 $(top_builddir)/src/daemon/libmicrohttpd.la \ 112 $(top_builddir)/src/daemon/libmicrohttpd.la \
113 @LIBCURL@ 113 @LIBCURL@
114 114
115daemontest_digestauth_SOURCES = \ 115test_digestauth_SOURCES = \
116 daemontest_digestauth.c 116 test_digestauth.c
117daemontest_digestauth_LDADD = \ 117test_digestauth_LDADD = \
118 $(top_builddir)/src/daemon/libmicrohttpd.la \ 118 $(top_builddir)/src/daemon/libmicrohttpd.la \
119 @LIBCURL@ 119 @LIBCURL@
120 120
121daemontest_digestauth_with_arguments_SOURCES = \ 121test_digestauth_with_arguments_SOURCES = \
122 daemontest_digestauth_with_arguments.c 122 test_digestauth_with_arguments.c
123daemontest_digestauth_with_arguments_LDADD = \ 123test_digestauth_with_arguments_LDADD = \
124 $(top_builddir)/src/daemon/libmicrohttpd.la \ 124 $(top_builddir)/src/daemon/libmicrohttpd.la \
125 @LIBCURL@ 125 @LIBCURL@
126 126
127daemontest_get_sendfile_SOURCES = \ 127test_get_sendfile_SOURCES = \
128 daemontest_get_sendfile.c 128 test_get_sendfile.c
129daemontest_get_sendfile_LDADD = \ 129test_get_sendfile_LDADD = \
130 $(top_builddir)/src/daemon/libmicrohttpd.la \ 130 $(top_builddir)/src/daemon/libmicrohttpd.la \
131 @LIBCURL@ 131 @LIBCURL@
132 132
133daemontest_urlparse_SOURCES = \ 133test_urlparse_SOURCES = \
134 daemontest_urlparse.c 134 test_urlparse.c
135daemontest_urlparse_LDADD = \ 135test_urlparse_LDADD = \
136 $(top_builddir)/src/daemon/libmicrohttpd.la \ 136 $(top_builddir)/src/daemon/libmicrohttpd.la \
137 @LIBCURL@ 137 @LIBCURL@
138 138
139daemontest_get_response_cleanup_SOURCES = \ 139test_get_response_cleanup_SOURCES = \
140 daemontest_get_response_cleanup.c 140 test_get_response_cleanup.c
141daemontest_get_response_cleanup_LDADD = \ 141test_get_response_cleanup_LDADD = \
142 $(top_builddir)/src/daemon/libmicrohttpd.la 142 $(top_builddir)/src/daemon/libmicrohttpd.la
143 143
144daemontest_get_chunked_SOURCES = \ 144test_get_chunked_SOURCES = \
145 daemontest_get_chunked.c 145 test_get_chunked.c
146daemontest_get_chunked_LDADD = \ 146test_get_chunked_LDADD = \
147 $(top_builddir)/src/daemon/libmicrohttpd.la \ 147 $(top_builddir)/src/daemon/libmicrohttpd.la \
148 @LIBCURL@ 148 @LIBCURL@
149 149
150daemontest_post_SOURCES = \ 150test_post_SOURCES = \
151 daemontest_post.c 151 test_post.c
152daemontest_post_LDADD = \ 152test_post_LDADD = \
153 $(top_builddir)/src/daemon/libmicrohttpd.la \ 153 $(top_builddir)/src/daemon/libmicrohttpd.la \
154 @LIBCURL@ 154 @LIBCURL@
155 155
156daemontest_process_headers_SOURCES = \ 156test_process_headers_SOURCES = \
157 daemontest_process_headers.c 157 test_process_headers.c
158daemontest_process_headers_LDADD = \ 158test_process_headers_LDADD = \
159 $(top_builddir)/src/daemon/libmicrohttpd.la \ 159 $(top_builddir)/src/daemon/libmicrohttpd.la \
160 @LIBCURL@ 160 @LIBCURL@
161 161
162daemontest_parse_cookies_SOURCES = \ 162test_parse_cookies_SOURCES = \
163 daemontest_parse_cookies.c 163 test_parse_cookies.c
164daemontest_parse_cookies_LDADD = \ 164test_parse_cookies_LDADD = \
165 $(top_builddir)/src/daemon/libmicrohttpd.la \ 165 $(top_builddir)/src/daemon/libmicrohttpd.la \
166 @LIBCURL@ 166 @LIBCURL@
167 167
168daemontest_process_arguments_SOURCES = \ 168test_process_arguments_SOURCES = \
169 daemontest_process_arguments.c 169 test_process_arguments.c
170daemontest_process_arguments_LDADD = \ 170test_process_arguments_LDADD = \
171 $(top_builddir)/src/daemon/libmicrohttpd.la \ 171 $(top_builddir)/src/daemon/libmicrohttpd.la \
172 @LIBCURL@ 172 @LIBCURL@
173 173
174daemontest_postform_SOURCES = \ 174test_postform_SOURCES = \
175 daemontest_postform.c 175 test_postform.c
176daemontest_postform_LDADD = \ 176test_postform_LDADD = \
177 $(top_builddir)/src/daemon/libmicrohttpd.la \ 177 $(top_builddir)/src/daemon/libmicrohttpd.la \
178 @LIBCURL@ 178 @LIBCURL@
179 179
180daemontest_post_loop_SOURCES = \ 180test_post_loop_SOURCES = \
181 daemontest_post_loop.c 181 test_post_loop.c
182daemontest_post_loop_LDADD = \ 182test_post_loop_LDADD = \
183 $(top_builddir)/src/daemon/libmicrohttpd.la \ 183 $(top_builddir)/src/daemon/libmicrohttpd.la \
184 @LIBCURL@ 184 @LIBCURL@
185 185
186daemontest_put_SOURCES = \ 186test_put_SOURCES = \
187 daemontest_put.c 187 test_put.c
188daemontest_put_LDADD = \ 188test_put_LDADD = \
189 $(top_builddir)/src/daemon/libmicrohttpd.la \ 189 $(top_builddir)/src/daemon/libmicrohttpd.la \
190 @LIBCURL@ 190 @LIBCURL@
191 191
192daemontest_put_chunked_SOURCES = \ 192test_put_chunked_SOURCES = \
193 daemontest_put_chunked.c 193 test_put_chunked.c
194daemontest_put_chunked_LDADD = \ 194test_put_chunked_LDADD = \
195 $(top_builddir)/src/daemon/libmicrohttpd.la \ 195 $(top_builddir)/src/daemon/libmicrohttpd.la \
196 @LIBCURL@ 196 @LIBCURL@
197 197
198daemontest_get11_SOURCES = \ 198test_get11_SOURCES = \
199 daemontest_get.c 199 test_get.c
200daemontest_get11_LDADD = \ 200test_get11_LDADD = \
201 $(top_builddir)/src/daemon/libmicrohttpd.la \ 201 $(top_builddir)/src/daemon/libmicrohttpd.la \
202 @LIBCURL@ 202 @LIBCURL@
203 203
204daemontest_get_sendfile11_SOURCES = \ 204test_get_sendfile11_SOURCES = \
205 daemontest_get_sendfile.c 205 test_get_sendfile.c
206daemontest_get_sendfile11_LDADD = \ 206test_get_sendfile11_LDADD = \
207 $(top_builddir)/src/daemon/libmicrohttpd.la \ 207 $(top_builddir)/src/daemon/libmicrohttpd.la \
208 @LIBCURL@ 208 @LIBCURL@
209 209
210daemontest_post11_SOURCES = \ 210test_post11_SOURCES = \
211 daemontest_post.c 211 test_post.c
212daemontest_post11_LDADD = \ 212test_post11_LDADD = \
213 $(top_builddir)/src/daemon/libmicrohttpd.la \ 213 $(top_builddir)/src/daemon/libmicrohttpd.la \
214 @LIBCURL@ 214 @LIBCURL@
215 215
216daemontest_postform11_SOURCES = \ 216test_postform11_SOURCES = \
217 daemontest_postform.c 217 test_postform.c
218daemontest_postform11_LDADD = \ 218test_postform11_LDADD = \
219 $(top_builddir)/src/daemon/libmicrohttpd.la \ 219 $(top_builddir)/src/daemon/libmicrohttpd.la \
220 @LIBCURL@ 220 @LIBCURL@
221 221
222daemontest_post_loop11_SOURCES = \ 222test_post_loop11_SOURCES = \
223 daemontest_post_loop.c 223 test_post_loop.c
224daemontest_post_loop11_LDADD = \ 224test_post_loop11_LDADD = \
225 $(top_builddir)/src/daemon/libmicrohttpd.la \ 225 $(top_builddir)/src/daemon/libmicrohttpd.la \
226 @LIBCURL@ 226 @LIBCURL@
227 227
228daemontest_put11_SOURCES = \ 228test_put11_SOURCES = \
229 daemontest_put.c 229 test_put.c
230daemontest_put11_LDADD = \ 230test_put11_LDADD = \
231 $(top_builddir)/src/daemon/libmicrohttpd.la \ 231 $(top_builddir)/src/daemon/libmicrohttpd.la \
232 @LIBCURL@ 232 @LIBCURL@
233 233
234daemontest_large_put_SOURCES = \ 234test_large_put_SOURCES = \
235 daemontest_large_put.c 235 test_large_put.c
236daemontest_large_put_LDADD = \ 236test_large_put_LDADD = \
237 $(top_builddir)/src/daemon/libmicrohttpd.la \ 237 $(top_builddir)/src/daemon/libmicrohttpd.la \
238 @LIBCURL@ 238 @LIBCURL@
239 239
240daemontest_large_put11_SOURCES = \ 240test_large_put11_SOURCES = \
241 daemontest_large_put.c 241 test_large_put.c
242daemontest_large_put11_LDADD = \ 242test_large_put11_LDADD = \
243 $(top_builddir)/src/daemon/libmicrohttpd.la \ 243 $(top_builddir)/src/daemon/libmicrohttpd.la \
244 @LIBCURL@ 244 @LIBCURL@
245 245
246daemontest_long_header_SOURCES = \ 246test_long_header_SOURCES = \
247 daemontest_long_header.c 247 test_long_header.c
248daemontest_long_header_LDADD = \ 248test_long_header_LDADD = \
249 $(top_builddir)/src/daemon/libmicrohttpd.la \ 249 $(top_builddir)/src/daemon/libmicrohttpd.la \
250 @LIBCURL@ 250 @LIBCURL@
251 251
252daemontest_long_header11_SOURCES = \ 252test_long_header11_SOURCES = \
253 daemontest_long_header.c 253 test_long_header.c
254daemontest_long_header11_LDADD = \ 254test_long_header11_LDADD = \
255 $(top_builddir)/src/daemon/libmicrohttpd.la \ 255 $(top_builddir)/src/daemon/libmicrohttpd.la \
256 @LIBCURL@ 256 @LIBCURL@
257 257
258daemontest_iplimit11_SOURCES = \ 258test_iplimit11_SOURCES = \
259 daemontest_iplimit.c 259 test_iplimit.c
260daemontest_iplimit11_LDADD = \ 260test_iplimit11_LDADD = \
261 $(top_builddir)/src/daemon/libmicrohttpd.la \ 261 $(top_builddir)/src/daemon/libmicrohttpd.la \
262 @LIBCURL@ 262 @LIBCURL@
263 263
264daemontest_termination_SOURCES = \ 264test_termination_SOURCES = \
265 daemontest_termination.c 265 test_termination.c
266daemontest_termination_LDADD = \ 266test_termination_LDADD = \
267 $(top_builddir)/src/daemon/libmicrohttpd.la \ 267 $(top_builddir)/src/daemon/libmicrohttpd.la \
268 @LIBCURL@ 268 @LIBCURL@
269 269
270daemontest_timeout_SOURCES = \ 270test_timeout_SOURCES = \
271 daemontest_timeout.c 271 test_timeout.c
272daemontest_timeout_LDADD = \ 272test_timeout_LDADD = \
273 $(top_builddir)/src/daemon/libmicrohttpd.la \ 273 $(top_builddir)/src/daemon/libmicrohttpd.la \
274 @LIBCURL@ 274 @LIBCURL@
275 275