aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/https/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/https/Makefile.am')
-rw-r--r--src/testcurl/https/Makefile.am15
1 files changed, 2 insertions, 13 deletions
diff --git a/src/testcurl/https/Makefile.am b/src/testcurl/https/Makefile.am
index 685984cb..ea336cb0 100644
--- a/src/testcurl/https/Makefile.am
+++ b/src/testcurl/https/Makefile.am
@@ -68,7 +68,6 @@ test_https_time_out_SOURCES = \
68 tls_test_common.h \ 68 tls_test_common.h \
69 tls_test_common.c 69 tls_test_common.c
70test_https_time_out_LDADD = \ 70test_https_time_out_LDADD = \
71 $(top_builddir)/src/testcurl/libcurl_version_check.a \
72 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 71 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
73 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 72 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
74 73
@@ -76,9 +75,9 @@ test_tls_options_SOURCES = \
76 test_tls_options.c \ 75 test_tls_options.c \
77 tls_test_keys.h \ 76 tls_test_keys.h \
78 tls_test_common.h \ 77 tls_test_common.h \
79 tls_test_common.c 78 tls_test_common.c \
79 curl_version_check.c
80test_tls_options_LDADD = \ 80test_tls_options_LDADD = \
81 $(top_builddir)/src/testcurl/libcurl_version_check.a \
82 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 81 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
83 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 82 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
84 83
@@ -92,7 +91,6 @@ test_https_get_parallel_CPPFLAGS = \
92test_https_get_parallel_CFLAGS = \ 91test_https_get_parallel_CFLAGS = \
93 $(PTHREAD_CFLAGS) $(AM_CFLAGS) 92 $(PTHREAD_CFLAGS) $(AM_CFLAGS)
94test_https_get_parallel_LDADD = \ 93test_https_get_parallel_LDADD = \
95 $(top_builddir)/src/testcurl/libcurl_version_check.a \
96 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 94 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
97 $(PTHREAD_LIBS) $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 95 $(PTHREAD_LIBS) $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
98 96
@@ -102,7 +100,6 @@ test_empty_response_SOURCES = \
102 tls_test_common.h \ 100 tls_test_common.h \
103 tls_test_common.c 101 tls_test_common.c
104test_empty_response_LDADD = \ 102test_empty_response_LDADD = \
105 $(top_builddir)/src/testcurl/libcurl_version_check.a \
106 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 103 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
107 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 104 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
108 105
@@ -116,7 +113,6 @@ test_https_get_parallel_threads_CPPFLAGS = \
116test_https_get_parallel_threads_CFLAGS = \ 113test_https_get_parallel_threads_CFLAGS = \
117 $(PTHREAD_CFLAGS) $(AM_CFLAGS) 114 $(PTHREAD_CFLAGS) $(AM_CFLAGS)
118test_https_get_parallel_threads_LDADD = \ 115test_https_get_parallel_threads_LDADD = \
119 $(top_builddir)/src/testcurl/libcurl_version_check.a \
120 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 116 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
121 $(PTHREAD_LIBS) $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 117 $(PTHREAD_LIBS) $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
122 118
@@ -126,7 +122,6 @@ test_tls_authentication_SOURCES = \
126 tls_test_common.h \ 122 tls_test_common.h \
127 tls_test_common.c 123 tls_test_common.c
128test_tls_authentication_LDADD = \ 124test_tls_authentication_LDADD = \
129 $(top_builddir)/src/testcurl/libcurl_version_check.a \
130 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 125 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
131 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 126 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
132 127
@@ -136,7 +131,6 @@ test_https_session_info_SOURCES = \
136 tls_test_common.h \ 131 tls_test_common.h \
137 tls_test_common.c 132 tls_test_common.c
138test_https_session_info_LDADD = \ 133test_https_session_info_LDADD = \
139 $(top_builddir)/src/testcurl/libcurl_version_check.a \
140 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 134 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
141 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 135 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
142 136
@@ -146,7 +140,6 @@ test_https_multi_daemon_SOURCES = \
146 tls_test_common.h \ 140 tls_test_common.h \
147 tls_test_common.c 141 tls_test_common.c
148test_https_multi_daemon_LDADD = \ 142test_https_multi_daemon_LDADD = \
149 $(top_builddir)/src/testcurl/libcurl_version_check.a \
150 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 143 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
151 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 144 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
152 145
@@ -156,7 +149,6 @@ test_https_get_SOURCES = \
156 tls_test_common.h \ 149 tls_test_common.h \
157 tls_test_common.c 150 tls_test_common.c
158test_https_get_LDADD = \ 151test_https_get_LDADD = \
159 $(top_builddir)/src/testcurl/libcurl_version_check.a \
160 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 152 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
161 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 153 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
162 154
@@ -166,7 +158,6 @@ test_https_get_iovec_SOURCES = \
166 tls_test_common.h \ 158 tls_test_common.h \
167 tls_test_common.c 159 tls_test_common.c
168test_https_get_iovec_LDADD = \ 160test_https_get_iovec_LDADD = \
169 $(top_builddir)/src/testcurl/libcurl_version_check.a \
170 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 161 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
171 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 162 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
172 163
@@ -180,7 +171,6 @@ test_https_sni_CPPFLAGS = \
180 $(AM_CPPFLAGS) \ 171 $(AM_CPPFLAGS) \
181 -DABS_SRCDIR=\"$(abs_srcdir)\" 172 -DABS_SRCDIR=\"$(abs_srcdir)\"
182test_https_sni_LDADD = \ 173test_https_sni_LDADD = \
183 $(top_builddir)/src/testcurl/libcurl_version_check.a \
184 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 174 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
185 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 175 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@
186endif 176endif
@@ -191,6 +181,5 @@ test_https_get_select_SOURCES = \
191 tls_test_common.h \ 181 tls_test_common.h \
192 tls_test_common.c 182 tls_test_common.c
193test_https_get_select_LDADD = \ 183test_https_get_select_LDADD = \
194 $(top_builddir)/src/testcurl/libcurl_version_check.a \
195 $(top_builddir)/src/microhttpd/libmicrohttpd.la \ 184 $(top_builddir)/src/microhttpd/libmicrohttpd.la \
196 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@ 185 $(MHD_TLS_LIB_LDFLAGS) $(MHD_TLS_LIBDEPS) @LIBGCRYPT_LIBS@ @LIBCURL@