aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/https/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/https/Makefile.am')
-rw-r--r--src/testcurl/https/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/testcurl/https/Makefile.am b/src/testcurl/https/Makefile.am
index f399fc17..2e81f3d0 100644
--- a/src/testcurl/https/Makefile.am
+++ b/src/testcurl/https/Makefile.am
@@ -8,6 +8,11 @@ if HAVE_GNUTLS_SNI
8 TEST_HTTPS_SNI = test_https_sni 8 TEST_HTTPS_SNI = test_https_sni
9endif 9endif
10 10
11if HAVE_POSIX_THREADS
12 HTTPS_PARALLEL_TESTS = test_https_get_parallel \
13 test_https_get_parallel_threads
14endif
15
11CPU_COUNT_DEF = -DCPU_COUNT=$(CPU_COUNT) 16CPU_COUNT_DEF = -DCPU_COUNT=$(CPU_COUNT)
12 17
13AM_CPPFLAGS = \ 18AM_CPPFLAGS = \
@@ -23,8 +28,7 @@ check_PROGRAMS = \
23 test_https_get \ 28 test_https_get \
24 $(TEST_HTTPS_SNI) \ 29 $(TEST_HTTPS_SNI) \
25 test_https_get_select \ 30 test_https_get_select \
26 test_https_get_parallel \ 31 $(HTTPS_PARALLEL_TESTS) \
27 test_https_get_parallel_threads \
28 test_https_session_info \ 32 test_https_session_info \
29 test_https_time_out \ 33 test_https_time_out \
30 test_empty_response 34 test_empty_response
@@ -38,8 +42,7 @@ TESTS = \
38 test_https_get \ 42 test_https_get \
39 $(TEST_HTTPS_SNI) \ 43 $(TEST_HTTPS_SNI) \
40 test_https_get_select \ 44 test_https_get_select \
41 test_https_get_parallel \ 45 $(HTTPS_PARALLEL_TESTS) \
42 test_https_get_parallel_threads \
43 test_https_session_info \ 46 test_https_session_info \
44 test_https_time_out \ 47 test_https_time_out \
45 test_tls_authentication \ 48 test_tls_authentication \