aboutsummaryrefslogtreecommitdiff
path: root/src/testcurl/https/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testcurl/https/Makefile.am')
-rw-r--r--src/testcurl/https/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/src/testcurl/https/Makefile.am b/src/testcurl/https/Makefile.am
index f07ecebc..5f620d06 100644
--- a/src/testcurl/https/Makefile.am
+++ b/src/testcurl/https/Makefile.am
@@ -34,8 +34,9 @@ if HAVE_GNUTLS_SNI
34 TEST_HTTPS_SNI = test_https_sni 34 TEST_HTTPS_SNI = test_https_sni
35endif 35endif
36 36
37if HAVE_POSIX_THREADS 37if !HAVE_GNUTLS_MTHREAD_BROKEN
38HTTPS_PARALLEL_TESTS = \ 38HTTPS_PARALLEL_TESTS = \
39 test_https_time_out \
39 test_https_get_parallel \ 40 test_https_get_parallel \
40 test_https_get_parallel_threads 41 test_https_get_parallel_threads
41endif 42endif
@@ -53,12 +54,6 @@ THREAD_ONLY_TESTS = \
53 test_https_get_iovec \ 54 test_https_get_iovec \
54 $(EMPTY_ITEM) 55 $(EMPTY_ITEM)
55 56
56if !HAVE_GNUTLS_MTHREAD_BROKEN
57THREAD_ONLY_TESTS += \
58 test_https_time_out \
59 $(EMPTY_ITEM)
60endif
61
62check_PROGRAMS = \ 57check_PROGRAMS = \
63 test_https_get_select 58 test_https_get_select
64 59