aboutsummaryrefslogtreecommitdiff
path: root/src/testspdy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testspdy/Makefile.am')
-rw-r--r--src/testspdy/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/testspdy/Makefile.am b/src/testspdy/Makefile.am
index 3cff9ac5..4042ef95 100644
--- a/src/testspdy/Makefile.am
+++ b/src/testspdy/Makefile.am
@@ -21,8 +21,8 @@ if !HAVE_W32
21PERF_GET_CONCURRENT=perf_get_concurrent 21PERF_GET_CONCURRENT=perf_get_concurrent
22endif 22endif
23 23
24check_PROGRAMS = \ 24if HAVE_SPDYLAY
25 test_daemon_start_stop \ 25check_PROGRAMS = \ test_daemon_start_stop \
26 test_daemon_start_stop_many \ 26 test_daemon_start_stop_many \
27 test_struct_namevalue \ 27 test_struct_namevalue \
28 test_new_connection \ 28 test_new_connection \
@@ -32,9 +32,13 @@ check_PROGRAMS = \
32 #test_requests_with_assets \ 32 #test_requests_with_assets \
33 test_misc \ 33 test_misc \
34 test_session_timeout 34 test_session_timeout
35else
36check_PROGRAMS =
37endif
35 38
36TESTS = $(check_PROGRAMS) 39TESTS = $(check_PROGRAMS)
37 40
41
38SPDY_SOURCES= \ 42SPDY_SOURCES= \
39 common.h common.c 43 common.h common.c
40 44
@@ -98,6 +102,7 @@ test_session_timeout_SOURCES = \
98 $(SPDY_SOURCES) 102 $(SPDY_SOURCES)
99test_session_timeout_LDADD = $(SPDY_LDADD) 103test_session_timeout_LDADD = $(SPDY_LDADD)
100 104
105if HAVE_SPDYLAY
101if HAVE_CURL_BINARY 106if HAVE_CURL_BINARY
102 107
103check_PROGRAMS += \ 108check_PROGRAMS += \
@@ -109,3 +114,4 @@ test_proxies_SOURCES = \
109test_proxies_LDADD = $(SPDY_LDADD) 114test_proxies_LDADD = $(SPDY_LDADD)
110 115
111endif 116endif
117endif