diff options
Diffstat (limited to 'src/testspdy/Makefile.am')
-rw-r--r-- | src/testspdy/Makefile.am | 21 |
1 files changed, 9 insertions, 12 deletions
diff --git a/src/testspdy/Makefile.am b/src/testspdy/Makefile.am index 4042ef95..cbad3389 100644 --- a/src/testspdy/Makefile.am +++ b/src/testspdy/Makefile.am | |||
@@ -21,20 +21,19 @@ if !HAVE_W32 | |||
21 | PERF_GET_CONCURRENT=perf_get_concurrent | 21 | PERF_GET_CONCURRENT=perf_get_concurrent |
22 | endif | 22 | endif |
23 | 23 | ||
24 | if HAVE_SPDYLAY | 24 | if HAVE_SPDYLAY |
25 | check_PROGRAMS = \ test_daemon_start_stop \ | 25 | SPDYLAY_CHECKS = test_new_connection test_request_response test_notls |
26 | endif | ||
27 | |||
28 | check_PROGRAMS = \ | ||
29 | test_daemon_start_stop \ | ||
26 | test_daemon_start_stop_many \ | 30 | test_daemon_start_stop_many \ |
27 | test_struct_namevalue \ | 31 | test_struct_namevalue \ |
28 | test_new_connection \ | ||
29 | test_request_response \ | ||
30 | test_notls \ | ||
31 | test_request_response_with_callback \ | 32 | test_request_response_with_callback \ |
33 | $(SPDYLAY_CHECKS) | ||
32 | #test_requests_with_assets \ | 34 | #test_requests_with_assets \ |
33 | test_misc \ | 35 | test_misc \ |
34 | test_session_timeout | 36 | test_session_timeout |
35 | else | ||
36 | check_PROGRAMS = | ||
37 | endif | ||
38 | 37 | ||
39 | TESTS = $(check_PROGRAMS) | 38 | TESTS = $(check_PROGRAMS) |
40 | 39 | ||
@@ -64,6 +63,7 @@ test_struct_namevalue_SOURCES = \ | |||
64 | $(SPDY_SOURCES) | 63 | $(SPDY_SOURCES) |
65 | test_struct_namevalue_LDADD = $(SPDY_LDADD) | 64 | test_struct_namevalue_LDADD = $(SPDY_LDADD) |
66 | 65 | ||
66 | if HAVE_SPDYLAY | ||
67 | test_new_connection_SOURCES = \ | 67 | test_new_connection_SOURCES = \ |
68 | test_new_connection.c \ | 68 | test_new_connection.c \ |
69 | $(SPDY_SOURCES) | 69 | $(SPDY_SOURCES) |
@@ -81,6 +81,7 @@ test_notls_SOURCES = \ | |||
81 | $(SPDY_SOURCES) | 81 | $(SPDY_SOURCES) |
82 | test_notls_LDADD = $(SPDY_LDADD) \ | 82 | test_notls_LDADD = $(SPDY_LDADD) \ |
83 | -lspdylay | 83 | -lspdylay |
84 | endif | ||
84 | 85 | ||
85 | test_request_response_with_callback_SOURCES = \ | 86 | test_request_response_with_callback_SOURCES = \ |
86 | test_request_response_with_callback.c \ | 87 | test_request_response_with_callback.c \ |
@@ -102,9 +103,7 @@ test_session_timeout_SOURCES = \ | |||
102 | $(SPDY_SOURCES) | 103 | $(SPDY_SOURCES) |
103 | test_session_timeout_LDADD = $(SPDY_LDADD) | 104 | test_session_timeout_LDADD = $(SPDY_LDADD) |
104 | 105 | ||
105 | if HAVE_SPDYLAY | ||
106 | if HAVE_CURL_BINARY | 106 | if HAVE_CURL_BINARY |
107 | |||
108 | check_PROGRAMS += \ | 107 | check_PROGRAMS += \ |
109 | test_proxies | 108 | test_proxies |
110 | 109 | ||
@@ -112,6 +111,4 @@ test_proxies_SOURCES = \ | |||
112 | test_proxies.c \ | 111 | test_proxies.c \ |
113 | $(SPDY_SOURCES) | 112 | $(SPDY_SOURCES) |
114 | test_proxies_LDADD = $(SPDY_LDADD) | 113 | test_proxies_LDADD = $(SPDY_LDADD) |
115 | |||
116 | endif | ||
117 | endif | 114 | endif |