aboutsummaryrefslogtreecommitdiff
path: root/src/testspdy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testspdy/Makefile.am')
-rw-r--r--src/testspdy/Makefile.am19
1 files changed, 12 insertions, 7 deletions
diff --git a/src/testspdy/Makefile.am b/src/testspdy/Makefile.am
index cbad3389..cedf37a1 100644
--- a/src/testspdy/Makefile.am
+++ b/src/testspdy/Makefile.am
@@ -21,19 +21,23 @@ if !HAVE_W32
21PERF_GET_CONCURRENT=perf_get_concurrent 21PERF_GET_CONCURRENT=perf_get_concurrent
22endif 22endif
23 23
24if HAVE_SPDYLAY
25 SPDYLAY_CHECKS = test_new_connection test_request_response test_notls
26endif
27 24
28check_PROGRAMS = \ 25check_PROGRAMS = \
29 test_daemon_start_stop \ 26 test_daemon_start_stop \
30 test_daemon_start_stop_many \ 27 test_daemon_start_stop_many \
31 test_struct_namevalue \ 28 test_struct_namevalue
29
30if HAVE_SPDYLAY
31 check_PROGRAMS += \
32 test_new_connection \
33 test_request_response \
34 test_notls \
32 test_request_response_with_callback \ 35 test_request_response_with_callback \
33 $(SPDYLAY_CHECKS)
34 #test_requests_with_assets \
35 test_misc \ 36 test_misc \
36 test_session_timeout 37 test_session_timeout
38 #test_requests_with_assets
39endif
40
37 41
38TESTS = $(check_PROGRAMS) 42TESTS = $(check_PROGRAMS)
39 43
@@ -81,7 +85,6 @@ test_notls_SOURCES = \
81 $(SPDY_SOURCES) 85 $(SPDY_SOURCES)
82test_notls_LDADD = $(SPDY_LDADD) \ 86test_notls_LDADD = $(SPDY_LDADD) \
83 -lspdylay 87 -lspdylay
84endif
85 88
86test_request_response_with_callback_SOURCES = \ 89test_request_response_with_callback_SOURCES = \
87 test_request_response_with_callback.c \ 90 test_request_response_with_callback.c \
@@ -112,3 +115,5 @@ test_proxies_SOURCES = \
112 $(SPDY_SOURCES) 115 $(SPDY_SOURCES)
113test_proxies_LDADD = $(SPDY_LDADD) 116test_proxies_LDADD = $(SPDY_LDADD)
114endif 117endif
118
119endif