aboutsummaryrefslogtreecommitdiff
path: root/src/testzzuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/testzzuf/Makefile.am')
-rw-r--r--src/testzzuf/Makefile.am107
1 files changed, 54 insertions, 53 deletions
diff --git a/src/testzzuf/Makefile.am b/src/testzzuf/Makefile.am
index a50c9e3a..688f0cbb 100644
--- a/src/testzzuf/Makefile.am
+++ b/src/testzzuf/Makefile.am
@@ -13,97 +13,98 @@ INCLUDES = $(PLIBC_INCLUDE) -I$(top_srcdir)/src/include
13EXTRA_DIST = README socat.c 13EXTRA_DIST = README socat.c
14 14
15check_PROGRAMS = \ 15check_PROGRAMS = \
16 daemontest_get \ 16 test_get \
17 daemontest_post \ 17 test_get_chunked \
18 daemontest_postform \ 18 test_post \
19 daemontest_put \ 19 test_post_form \
20 daemontest_large_put \ 20 test_put \
21 daemontest_get11 \ 21 test_put_chunked \
22 daemontest_post11 \ 22 test_put_large \
23 daemontest_postform11 \ 23 test_get11 \
24 daemontest_put11 \ 24 test_post11 \
25 daemontest_large_put11 \ 25 test_post_form11 \
26 daemontest_long_header \ 26 test_put11 \
27 daemontest_get_chunked \ 27 test_put_large11 \
28 daemontest_put_chunked 28 test_long_header
29 29
30TESTS = $(check_PROGRAMS) 30TESTS = $(check_PROGRAMS)
31 31
32daemontest_get_SOURCES = \ 32test_get_SOURCES = \
33 daemontest_get.c 33 test_get.c
34daemontest_get_LDADD = \ 34test_get_LDADD = \
35 $(top_builddir)/src/daemon/libmicrohttpd.la \ 35 $(top_builddir)/src/daemon/libmicrohttpd.la \
36 @LIBCURL@ 36 @LIBCURL@
37 37
38daemontest_get_chunked_SOURCES = \ 38test_get_chunked_SOURCES = \
39 daemontest_get_chunked.c 39 test_get_chunked.c
40daemontest_get_chunked_LDADD = \ 40test_get_chunked_LDADD = \
41 $(top_builddir)/src/daemon/libmicrohttpd.la \ 41 $(top_builddir)/src/daemon/libmicrohttpd.la \
42 @LIBCURL@ 42 @LIBCURL@
43 43
44daemontest_post_SOURCES = \ 44test_post_SOURCES = \
45 daemontest_post.c 45 test_post.c
46daemontest_post_LDADD = \ 46test_post_LDADD = \
47 $(top_builddir)/src/daemon/libmicrohttpd.la \ 47 $(top_builddir)/src/daemon/libmicrohttpd.la \
48 @LIBCURL@ 48 @LIBCURL@
49 49
50daemontest_postform_SOURCES = \ 50test_post_form_SOURCES = \
51 daemontest_postform.c 51 test_post_form.c
52daemontest_postform_LDADD = \ 52test_post_form_LDADD = \
53 $(top_builddir)/src/daemon/libmicrohttpd.la \ 53 $(top_builddir)/src/daemon/libmicrohttpd.la \
54 @LIBCURL@ 54 @LIBCURL@
55 55
56daemontest_put_SOURCES = \ 56test_put_SOURCES = \
57 daemontest_put.c 57 test_put.c
58daemontest_put_LDADD = \ 58test_put_LDADD = \
59 $(top_builddir)/src/daemon/libmicrohttpd.la \ 59 $(top_builddir)/src/daemon/libmicrohttpd.la \
60 @LIBCURL@ 60 @LIBCURL@
61 61
62daemontest_put_chunked_SOURCES = \ 62test_put_chunked_SOURCES = \
63 daemontest_put_chunked.c 63 test_put_chunked.c
64daemontest_put_chunked_LDADD = \ 64test_put_chunked_LDADD = \
65 $(top_builddir)/src/daemon/libmicrohttpd.la \ 65 $(top_builddir)/src/daemon/libmicrohttpd.la \
66 @LIBCURL@ 66 @LIBCURL@
67 67
68daemontest_get11_SOURCES = \ 68test_put_large_SOURCES = \
69 daemontest_get.c 69 test_put_large.c
70daemontest_get11_LDADD = \ 70test_put_large_LDADD = \
71 $(top_builddir)/src/daemon/libmicrohttpd.la \ 71 $(top_builddir)/src/daemon/libmicrohttpd.la \
72 @LIBCURL@ 72 @LIBCURL@
73 73
74daemontest_post11_SOURCES = \ 74
75 daemontest_post.c 75
76daemontest_post11_LDADD = \ 76test_get11_SOURCES = \
77 test_get.c
78test_get11_LDADD = \
77 $(top_builddir)/src/daemon/libmicrohttpd.la \ 79 $(top_builddir)/src/daemon/libmicrohttpd.la \
78 @LIBCURL@ 80 @LIBCURL@
79 81
80daemontest_postform11_SOURCES = \ 82test_post11_SOURCES = \
81 daemontest_postform.c 83 test_post.c
82daemontest_postform11_LDADD = \ 84test_post11_LDADD = \
83 $(top_builddir)/src/daemon/libmicrohttpd.la \ 85 $(top_builddir)/src/daemon/libmicrohttpd.la \
84 @LIBCURL@ 86 @LIBCURL@
85 87
86daemontest_put11_SOURCES = \ 88test_post_form11_SOURCES = \
87 daemontest_put.c 89 test_post_form.c
88daemontest_put11_LDADD = \ 90test_post_form11_LDADD = \
89 $(top_builddir)/src/daemon/libmicrohttpd.la \ 91 $(top_builddir)/src/daemon/libmicrohttpd.la \
90 @LIBCURL@ 92 @LIBCURL@
91 93
92 94test_put11_SOURCES = \
93daemontest_large_put_SOURCES = \ 95 test_put.c
94 daemontest_large_put.c 96test_put11_LDADD = \
95daemontest_large_put_LDADD = \
96 $(top_builddir)/src/daemon/libmicrohttpd.la \ 97 $(top_builddir)/src/daemon/libmicrohttpd.la \
97 @LIBCURL@ 98 @LIBCURL@
98 99
99daemontest_large_put11_SOURCES = \ 100test_put_large11_SOURCES = \
100 daemontest_large_put.c 101 test_put_large.c
101daemontest_large_put11_LDADD = \ 102test_put_large11_LDADD = \
102 $(top_builddir)/src/daemon/libmicrohttpd.la \ 103 $(top_builddir)/src/daemon/libmicrohttpd.la \
103 @LIBCURL@ 104 @LIBCURL@
104 105
105daemontest_long_header_SOURCES = \ 106test_long_header_SOURCES = \
106 daemontest_long_header.c 107 test_long_header.c
107daemontest_long_header_LDADD = \ 108test_long_header_LDADD = \
108 $(top_builddir)/src/daemon/libmicrohttpd.la \ 109 $(top_builddir)/src/daemon/libmicrohttpd.la \
109 @LIBCURL@ 110 @LIBCURL@