summaryrefslogtreecommitdiff
path: root/prototype_2016/resources/qml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'prototype_2016/resources/qml/CMakeLists.txt')
-rw-r--r--prototype_2016/resources/qml/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/prototype_2016/resources/qml/CMakeLists.txt b/prototype_2016/resources/qml/CMakeLists.txt
new file mode 100644
index 0000000..a4f9ab6
--- /dev/null
+++ b/prototype_2016/resources/qml/CMakeLists.txt
@@ -0,0 +1,10 @@
1set(SOURCES main.cpp demo.qrc)
2file(GLOB_RECURSE QML_SOURCES
3 RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "*.qml")
4
5add_executable(fluid-demo ${SOURCES} ${QML_SOURCES})
6target_link_libraries(fluid-demo Qt5::Gui Qt5::Qml Qt5::QuickControls2)
7
8install(TARGETS fluid-demo
9 BUNDLE DESTINATION .
10 RUNTIME DESTINATION ${BIN_INSTALL_DIR})