aboutsummaryrefslogtreecommitdiff
path: root/src/dns/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-13 22:10:16 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-13 22:10:16 +0000
commitfb1390dfeb7e98a404207988f13341522f3692b6 (patch)
tree8568f457c1f6cecf4486b6cedea839c39758e0a0 /src/dns/Makefile.am
parent8f2925beae5b4791ff1c0a592d10ad69f249bc7d (diff)
downloadgnunet-fb1390dfeb7e98a404207988f13341522f3692b6.tar.gz
gnunet-fb1390dfeb7e98a404207988f13341522f3692b6.zip
improving code and build system to be in line with gnunet access control model for services as described at https://gnunet.org/gnunet-access-control-model
Diffstat (limited to 'src/dns/Makefile.am')
-rw-r--r--src/dns/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/dns/Makefile.am b/src/dns/Makefile.am
index f7376a111..99e78d7d6 100644
--- a/src/dns/Makefile.am
+++ b/src/dns/Makefile.am
@@ -20,8 +20,11 @@ HIJACKBIN = gnunet-helper-hijack-dns gnunet-helper-dns
20install-exec-hook: 20install-exec-hook:
21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-hijack-dns || true 21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-hijack-dns || true
22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-hijack-dns || true 22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-hijack-dns || true
23 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-dns || true 23 $(SUDO_BINARY) chown root $(bindir)/gnunet-helper-dns || true
24 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-dns || true 24 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-helper-dns || true
25 $(SUDO_BINARY) chmod 4750 $(bindir)/gnunet-helper-dns || true
26 $(SUDO_BINARY) chgrp $(GNUNETDNS_GROUP) $(bindir)/gnunet-service-dns-new || true
27 $(SUDO_BINARY) chmod 2755 $(bindir)/gnunet-helper-dns || true
25else 28else
26install-exec-hook: 29install-exec-hook:
27endif 30endif