aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-12-23 19:02:54 +0000
committerChristian Grothoff <christian@grothoff.org>2013-12-23 19:02:54 +0000
commite548255ba53e4ae6bc92054c9ce9ee0674d06d23 (patch)
tree36be45ef8aa82efab305814035b071ccf347488d /src/set/Makefile.am
parent0bbed9dcf7dbdb3cb225e370b9eb3e792c2e0c82 (diff)
downloadgnunet-e548255ba53e4ae6bc92054c9ce9ee0674d06d23.tar.gz
gnunet-e548255ba53e4ae6bc92054c9ce9ee0674d06d23.zip
-fix build system issues
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
index a2ca25f94..124818ce4 100644
--- a/src/set/Makefile.am
+++ b/src/set/Makefile.am
@@ -8,7 +8,7 @@ pkgcfg_DATA = \
8 set.conf 8 set.conf
9 9
10if MINGW 10if MINGW
11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
12endif 12endif
13 13
14if USE_COVERAGE 14if USE_COVERAGE
@@ -43,11 +43,12 @@ gnunet_set_ibf_profiler_LDADD = \
43 $(GN_LIBINTL) 43 $(GN_LIBINTL)
44 44
45gnunet_service_set_SOURCES = \ 45gnunet_service_set_SOURCES = \
46 gnunet-service-set.c \ 46 gnunet-service-set.c gnunet-service-set.h \
47 gnunet-service-set_union.c \ 47 gnunet-service-set_union.c \
48 gnunet-service-set_intersection.c \ 48 gnunet-service-set_intersection.c \
49 ibf.c \ 49 ibf.c ibf.h \
50 strata_estimator.c 50 strata_estimator.c strata_estimator.h \
51 set_protocol.h
51gnunet_service_set_LDADD = \ 52gnunet_service_set_LDADD = \
52 $(top_builddir)/src/util/libgnunetutil.la \ 53 $(top_builddir)/src/util/libgnunetutil.la \
53 $(top_builddir)/src/core/libgnunetcore.la \ 54 $(top_builddir)/src/core/libgnunetcore.la \
@@ -56,7 +57,7 @@ gnunet_service_set_LDADD = \
56 $(GN_LIBINTL) 57 $(GN_LIBINTL)
57 58
58libgnunetset_la_SOURCES = \ 59libgnunetset_la_SOURCES = \
59 set_api.c 60 set_api.c set.h
60libgnunetset_la_LIBADD = \ 61libgnunetset_la_LIBADD = \
61 $(top_builddir)/src/util/libgnunetutil.la \ 62 $(top_builddir)/src/util/libgnunetutil.la \
62 $(LTLIBINTL) 63 $(LTLIBINTL)