aboutsummaryrefslogtreecommitdiff
path: root/src/set/Makefile.am
diff options
context:
space:
mode:
authorFlorian Dold <florian.dold@gmail.com>2013-04-16 18:32:56 +0000
committerFlorian Dold <florian.dold@gmail.com>2013-04-16 18:32:56 +0000
commite77e2db24ef3681f207521e539a2c1ca3584efda (patch)
tree1bb5afd004527fa6ce1ca213571dcbc60fa55ef6 /src/set/Makefile.am
parentc5a460ec22898e2ce2c5c5b1d1a2abb083b8fc8d (diff)
downloadgnunet-e77e2db24ef3681f207521e539a2c1ca3584efda.tar.gz
gnunet-e77e2db24ef3681f207521e539a2c1ca3584efda.zip
added skeleton for gnunet set
Diffstat (limited to 'src/set/Makefile.am')
-rw-r--r--src/set/Makefile.am72
1 files changed, 72 insertions, 0 deletions
diff --git a/src/set/Makefile.am b/src/set/Makefile.am
new file mode 100644
index 000000000..fb6aa5b21
--- /dev/null
+++ b/src/set/Makefile.am
@@ -0,0 +1,72 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7pkgcfg_DATA = \
8 set.conf
9
10if MINGW
11 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
12endif
13
14if USE_COVERAGE
15 AM_CFLAGS = -fprofile-arcs -ftest-coverage
16endif
17
18bin_PROGRAMS = \
19 gnunet-set
20
21libexec_PROGRAMS = \
22 gnunet-service-set
23
24lib_LTLIBRARIES = \
25 libgnunetset.la
26
27gnunet_set_SOURCES = \
28 gnunet-set.c
29gnunet_set_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/set/libgnunetset.la \
32 $(top_builddir)/src/testbed/libgnunettestbed.la \
33 $(GN_LIBINTL)
34gnunet_set_DEPENDENCIES = \
35 libgnunetset.la
36
37gnunet_service_set_SOURCES = \
38 gnunet-service-set.c \
39 ibf.c \
40 strata_estimator.c
41gnunet_service_set_LDADD = \
42 $(top_builddir)/src/util/libgnunetutil.la \
43 $(top_builddir)/src/core/libgnunetcore.la \
44 $(top_builddir)/src/stream/libgnunetstream.la \
45 $(top_builddir)/src/mesh/libgnunetmesh.la \
46 $(GN_LIBINTL)
47
48libgnunetset_la_SOURCES = \
49 set_api.c
50libgnunetset_la_LIBADD = \
51 $(top_builddir)/src/util/libgnunetutil.la \
52 $(LTLIBINTL)
53libgnunetset_la_LDFLAGS = \
54 $(GN_LIB_LDFLAGS)
55
56check_PROGRAMS = \
57 test_set_api
58
59if ENABLE_TEST_RUN
60TESTS = $(check_PROGRAMS)
61endif
62
63test_set_api_SOURCES = \
64 test_set_api.c
65test_set_api_LDADD = \
66 $(top_builddir)/src/util/libgnunetutil.la \
67 $(top_builddir)/src/testing/libgnunettesting.la \
68 $(top_builddir)/src/set/libgnunetset.la
69
70EXTRA_DIST = \
71 test_set.conf
72