aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2021-10-15 21:02:03 +0200
committert3sserakt <t3ss@posteo.de>2021-10-15 21:02:03 +0200
commit513f23e74650db9408267e82ef8bcb8f770d1015 (patch)
tree312db7072dc444e9d1e6a13000b79482eb14de82 /src/transport/Makefile.am
parentd190d23831dae1a77075557f2ff6e0c713d747d5 (diff)
parentd64ac269856744b9bab170964e1d6f36896ecc55 (diff)
downloadgnunet-513f23e74650db9408267e82ef8bcb8f770d1015.tar.gz
gnunet-513f23e74650db9408267e82ef8bcb8f770d1015.zip
Merge branch 'master' into dev/t3ss/tng
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am53
1 files changed, 0 insertions, 53 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 73544a8d5..d281c4ffb 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -128,11 +128,9 @@ noinst_PROGRAMS = \
128 $(WLAN_BIN_SENDER) \ 128 $(WLAN_BIN_SENDER) \
129 $(WLAN_BIN_RECEIVER) 129 $(WLAN_BIN_RECEIVER)
130 130
131if HAVE_TESTING
132TESTING_LIBS = \ 131TESTING_LIBS = \
133 libgnunettransporttesting.la \ 132 libgnunettransporttesting.la \
134 libgnunettransporttesting2.la 133 libgnunettransporttesting2.la
135endif
136 134
137lib_LTLIBRARIES = \ 135lib_LTLIBRARIES = \
138 libgnunettransport.la \ 136 libgnunettransport.la \
@@ -161,16 +159,10 @@ libgnunettransporttesting_la_LDFLAGS = \
161 159
162libgnunettransporttesting2_la_SOURCES = \ 160libgnunettransporttesting2_la_SOURCES = \
163 transport_api_cmd_connecting_peers.c \ 161 transport_api_cmd_connecting_peers.c \
164 transport_api_cmd_connecting_peers_v2.c \
165 transport_api_cmd_connecting_peers_v3.c \
166 transport_api_cmd_backchannel_check.c \ 162 transport_api_cmd_backchannel_check.c \
167 transport_api_cmd_start_peer.c \ 163 transport_api_cmd_start_peer.c \
168 transport_api_cmd_start_peer_v2.c \
169 transport_api_cmd_start_peer_v3.c \
170 transport_api_cmd_stop_peer.c \ 164 transport_api_cmd_stop_peer.c \
171 transport_api_cmd_send_simple.c \ 165 transport_api_cmd_send_simple.c \
172 transport_api_cmd_send_simple_v2.c \
173 transport_api_cmd_send_simple_v3.c \
174 transport-testing2.c transport-testing2.h \ 166 transport-testing2.c transport-testing2.h \
175 transport-testing-cmds.h \ 167 transport-testing-cmds.h \
176 transport-testing-filenames2.c \ 168 transport-testing-filenames2.c \
@@ -398,7 +390,6 @@ plugin_LTLIBRARIES = \
398 $(WLAN_PLUGIN_LA) \ 390 $(WLAN_PLUGIN_LA) \
399 $(BT_PLUGIN_LA) \ 391 $(BT_PLUGIN_LA) \
400 libgnunet_test_transport_plugin_cmd_simple_send.la \ 392 libgnunet_test_transport_plugin_cmd_simple_send.la \
401 libgnunet_test_transport_plugin_cmd_simple_send_v2.la \
402 libgnunet_test_transport_plugin_cmd_udp_backchannel.la 393 libgnunet_test_transport_plugin_cmd_udp_backchannel.la
403 394
404libgnunet_test_transport_plugin_cmd_udp_backchannel_la_SOURCES = \ 395libgnunet_test_transport_plugin_cmd_udp_backchannel_la_SOURCES = \
@@ -435,23 +426,6 @@ libgnunet_test_transport_plugin_cmd_simple_send_la_LIBADD = \
435libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \ 426libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \
436 $(GN_PLUGIN_LDFLAGS) 427 $(GN_PLUGIN_LDFLAGS)
437 428
438libgnunet_test_transport_plugin_cmd_simple_send_v2_la_SOURCES = \
439 test_transport_plugin_cmd_simple_send_v2.c
440libgnunet_test_transport_plugin_cmd_simple_send_v2_la_LIBADD = \
441 libgnunettransporttesting2.la \
442 libgnunettransportapplication.la \
443 libgnunettransportcore.la \
444 $(top_builddir)/src/testing/libgnunettesting.la \
445 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
446 $(top_builddir)/src/statistics/libgnunetstatistics.la \
447 $(top_builddir)/src/hello/libgnunethello.la \
448 $(top_builddir)/src/ats/libgnunetats.la \
449 $(top_builddir)/src/arm/libgnunetarm.la \
450 $(top_builddir)/src/util/libgnunetutil.la \
451 $(LTLIBINTL)
452libgnunet_test_transport_plugin_cmd_simple_send_v2_la_LDFLAGS = \
453 $(GN_PLUGIN_LDFLAGS)
454
455if HAVE_EXPERIMENTAL 429if HAVE_EXPERIMENTAL
456plugin_LTLIBRARIES += \ 430plugin_LTLIBRARIES += \
457 libgnunet_plugin_transport_udp.la 431 libgnunet_plugin_transport_udp.la
@@ -596,10 +570,7 @@ libgnunet_plugin_transport_https_server_la_LDFLAGS = \
596libgnunet_plugin_transport_https_server_la_CFLAGS = \ 570libgnunet_plugin_transport_https_server_la_CFLAGS = \
597 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS 571 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS
598 572
599if HAVE_TESTING
600check_PROGRAMS = \ 573check_PROGRAMS = \
601 test_transport_simple_send \
602 test_transport_simple_send_v2 \
603 test_transport_start_with_config \ 574 test_transport_start_with_config \
604 test_transport_address_switch_tcp \ 575 test_transport_address_switch_tcp \
605 test_transport_testing_startstop \ 576 test_transport_testing_startstop \
@@ -684,7 +655,6 @@ check_PROGRAMS += \
684 test_communicator_backchannel-udp \ 655 test_communicator_backchannel-udp \
685 test_communicator_bidirect-tcp 656 test_communicator_bidirect-tcp
686endif 657endif
687endif
688 658
689if ENABLE_TEST_RUN 659if ENABLE_TEST_RUN
690AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 660AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
@@ -749,8 +719,6 @@ test_transport_api_slow_ats
749endif 719endif
750if HAVE_EXPERIMENTAL 720if HAVE_EXPERIMENTAL
751TESTS += \ 721TESTS += \
752 test_transport_simple_send \
753 test_transport_simple_send_v2 \
754 test_transport_start_with_config \ 722 test_transport_start_with_config \
755 test_transport_address_switch_udp \ 723 test_transport_address_switch_udp \
756 test_plugin_udp \ 724 test_plugin_udp \
@@ -771,7 +739,6 @@ endif
771 739
772check_SCRIPTS= \ 740check_SCRIPTS= \
773 test_transport_simple_send.sh \ 741 test_transport_simple_send.sh \
774 test_transport_simple_send_v2.sh \
775 test_transport_udp_backchannel.sh 742 test_transport_udp_backchannel.sh
776 743
777test_transport_start_with_config_SOURCES = \ 744test_transport_start_with_config_SOURCES = \
@@ -784,26 +751,6 @@ test_transport_start_with_config_LDADD = \
784 libgnunettransportcore.la \ 751 libgnunettransportcore.la \
785 libgnunettransporttesting2.la 752 libgnunettransporttesting2.la
786 753
787test_transport_simple_send_SOURCES = \
788 test_transport_simple_send.c
789test_transport_simple_send_LDADD = \
790 $(top_builddir)/src/testing/libgnunettesting.la \
791 $(top_builddir)/src/util/libgnunetutil.la \
792 $(top_builddir)/src/testbed/libgnunettestbed.la \
793 $(top_builddir)/src/hello/libgnunethello.la \
794 libgnunettransportcore.la \
795 libgnunettransporttesting2.la
796
797test_transport_simple_send_v2_SOURCES = \
798 test_transport_simple_send_v2.c
799test_transport_simple_send_v2_LDADD = \
800 $(top_builddir)/src/testing/libgnunettesting.la \
801 $(top_builddir)/src/util/libgnunetutil.la \
802 $(top_builddir)/src/testbed/libgnunettestbed.la \
803 $(top_builddir)/src/hello/libgnunethello.la \
804 libgnunettransportcore.la \
805 libgnunettransporttesting2.la
806
807test_transport_testing_startstop_SOURCES = \ 754test_transport_testing_startstop_SOURCES = \
808 test_transport_testing_startstop.c 755 test_transport_testing_startstop.c
809test_transport_testing_startstop_LDADD = \ 756test_transport_testing_startstop_LDADD = \