aboutsummaryrefslogtreecommitdiff
path: root/doc/examples/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-03-29 16:23:19 +0000
committerChristian Grothoff <christian@grothoff.org>2013-03-29 16:23:19 +0000
commita80338c1926c30ae662444347e94fa94c51ea264 (patch)
tree50788b3db47ab4ba5889ab1b1946663138a0bed9 /doc/examples/Makefile.am
parent2a7101a19bd14fa62c510139d33195c1b52e9613 (diff)
downloadlibmicrohttpd-a80338c1926c30ae662444347e94fa94c51ea264.tar.gz
libmicrohttpd-a80338c1926c30ae662444347e94fa94c51ea264.zip
-also build examples
Diffstat (limited to 'doc/examples/Makefile.am')
-rw-r--r--doc/examples/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/doc/examples/Makefile.am b/doc/examples/Makefile.am
new file mode 100644
index 00000000..5c1ec7f5
--- /dev/null
+++ b/doc/examples/Makefile.am
@@ -0,0 +1,76 @@
1SUBDIRS = .
2
3if USE_PRIVATE_PLIBC_H
4 PLIBC_INCLUDE = -I$(top_srcdir)/src/include/plibc
5endif
6
7AM_CPPFLAGS = \
8 $(PLIBC_INCLUDE) \
9 -I$(top_srcdir)/src/include \
10 @LIBGCRYPT_CFLAGS@
11
12if USE_COVERAGE
13 AM_CFLAGS = --coverage
14endif
15
16# example programs
17noinst_PROGRAMS = \
18 basicauthentication \
19 hellobrowser \
20 logging \
21 responseheaders \
22 sessions
23
24if ENABLE_HTTPS
25noinst_PROGRAMS += \
26 tlsauthentication
27endif
28if HAVE_POSTPROCESSOR
29noinst_PROGRAMS += simplepost largepost
30endif
31
32if HAVE_W32
33IBERTY=-liberty
34endif
35
36basicauthentication_SOURCES = \
37 basicauthentication.c
38basicauthentication_LDADD = \
39 $(top_builddir)/src/daemon/libmicrohttpd.la
40
41hellobrowser_SOURCES = \
42 hellobrowser.c
43hellobrowser_LDADD = \
44 $(top_builddir)/src/daemon/libmicrohttpd.la
45
46logging_SOURCES = \
47 logging.c
48logging_LDADD = \
49 $(top_builddir)/src/daemon/libmicrohttpd.la \
50 $(IBERTY)
51
52responseheaders_SOURCES = \
53 responseheaders.c
54responseheaders_LDADD = \
55 $(top_builddir)/src/daemon/libmicrohttpd.la
56
57sessions_SOURCES = \
58 sessions.c
59sessions_LDADD = \
60 $(top_builddir)/src/daemon/libmicrohttpd.la
61
62tlsauthentication_SOURCES = \
63 tlsauthentication.c
64tlsauthentication_LDADD = \
65 $(top_builddir)/src/daemon/libmicrohttpd.la
66
67simplepost_SOURCES = \
68 simplepost.c
69simplepost_LDADD = \
70 $(top_builddir)/src/daemon/libmicrohttpd.la
71
72largepost_SOURCES = \
73 largepost.c
74largepost_LDADD = \
75 $(top_builddir)/src/daemon/libmicrohttpd.la
76