aboutsummaryrefslogtreecommitdiff
path: root/src/microhttpd/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-08-27 19:01:52 +0000
committerChristian Grothoff <christian@grothoff.org>2016-08-27 19:01:52 +0000
commitcfbd80d1e127a98175c0276b7ffbcfb2475fea3b (patch)
tree531f11157d4f040720b446fa777a2879ab380f9a /src/microhttpd/Makefile.am
parente0a43cb194fd22ceaed6905d964f2fcd829b933d (diff)
downloadlibmicrohttpd-cfbd80d1e127a98175c0276b7ffbcfb2475fea3b.tar.gz
libmicrohttpd-cfbd80d1e127a98175c0276b7ffbcfb2475fea3b.zip
add testcase for HTTP Upgrade
Diffstat (limited to 'src/microhttpd/Makefile.am')
-rw-r--r--src/microhttpd/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/microhttpd/Makefile.am b/src/microhttpd/Makefile.am
index 34a89984..6973af8a 100644
--- a/src/microhttpd/Makefile.am
+++ b/src/microhttpd/Makefile.am
@@ -143,7 +143,8 @@ check_PROGRAMS = \
143 test_str_to_value \ 143 test_str_to_value \
144 test_shutdown_select \ 144 test_shutdown_select \
145 test_shutdown_poll \ 145 test_shutdown_poll \
146 test_daemon 146 test_daemon \
147 test_upgrade
147 148
148if HAVE_POSTPROCESSOR 149if HAVE_POSTPROCESSOR
149check_PROGRAMS += \ 150check_PROGRAMS += \
@@ -165,6 +166,11 @@ test_daemon_SOURCES = \
165test_daemon_LDADD = \ 166test_daemon_LDADD = \
166 $(top_builddir)/src/microhttpd/libmicrohttpd.la 167 $(top_builddir)/src/microhttpd/libmicrohttpd.la
167 168
169test_upgrade_SOURCES = \
170 test_upgrade.c
171test_upgrade_LDADD = \
172 $(top_builddir)/src/microhttpd/libmicrohttpd.la
173
168test_postprocessor_SOURCES = \ 174test_postprocessor_SOURCES = \
169 test_postprocessor.c 175 test_postprocessor.c
170test_postprocessor_CPPFLAGS = \ 176test_postprocessor_CPPFLAGS = \